Trouble with Mullvad VPN GPG verification

So I have done exactly these steps- repeatedly. I did it from the AUR page, from the Mullvad page, and to be sure I just cut and pasted from your discussion above. Mullvad keys seem to exist in my system: gpg --list-keys

pub rsa4096 2015-07-17 [SC]
uid [ unknown] Mozilla Software Releases
sub rsa4096 2019-05-30 [S] [expires: 2021-05-29]

pub rsa4096 2016-10-27 [SC]
uid [ultimate] Mullvad (code signing)
sub rsa4096 2016-10-27 [E]
sub rsa4096 2016-10-27 [S]
Yet I get the gpg error when trying to install Mullvad. I’d appreciate any light you, or anyone else might shed on this.
Thanks in advance

Are you installing mullvad-vpn or mullvad-vpn-bin? For the former, you also need the developer key for the signed commit. The instructions are in the pinned comment on the AUR page.

In the future, please create your own thread (I’ve done that for you) instead of hijacking another thread that’s been resolved.

It appeared solved by fortuity as the solution appeared not to be reproduceable, and my issue spoke directly to the published solution. On most forums the snarky reply is “Didn’t you search the forums? Why the hell are you starting a new thread?” - and I’d bet that would be the exact response I’d have gotten here had I done so judging by your reply. But thanks for the help

Also- you were exactly right. Appreciated.

In that thread, the issue was a DNS problem on the user’s end. I admit it wasn’t easy to tell what solved it as he didn’t figure out it was a DNS issue until he followed the instructions properly. You had a similar issue, however not related.

I understand it can be hard to decide whether to chime in on an existing topic or create your own sometimes. Unless it’s an open-ended issue that multiple people are reporting, it’s best is to create your own topic and reference the related post(s) that you found.

You’re welcome and welcome to the forum. :wave:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.