Installer "Failed to resize partition"

Hello, I’m trying to install Manjaro XFCE alongside a Windows 7 install, however the installer fails before getting to 1%. The error message is as follows:

The installer failed to resize partition /dev/sda2 on disk ‘WDC WD10EZEX-00BN5A0’.
Shrink partition ‘/dev/sda2’ from 931.41 GiB to 887.40 GiB
Job: Check file system on partition ‘/dev/sda2’
Command: ntfsresize --no-progress-bar --info --force --verbose /dev/sda2
Checking partition ‘/dev/sda2’ before resize/move failed.

I made sure the disk is not mounted and that there is enough space left and the error persists (this also happens regardless of how much space I give Manjaro, within my free disk space), I am using a live USB. If there is any log files I can also send to make the error more clear please let me know. I am new to all this so any assistance is appreciated.

What happens if you resize your partition from GParted before starting the installation and manually add a new partition for your Manjaro install?

GParted hung completely on the “ntfsresize -i -f -v ‘/dev/sda2’” command after about a minute, and then a minute later gave an error saying the operation failed.

“Shrink /dev/sda2 from 931.41 GiB to 845.72 GiB” (Error)
-“calibrate /dev/sda2” (Successful)
–path: /dev/sda2 (partition)
–start: 206848
–end: 1953521663
–size: 1953314816 (931.41 GiB)

-“check file system on /dev/sda2 for errors and (if possible) fix them” (Error)
–ntfsresize -i -f -v ‘dev/sda2’ (Error)

Trying to open the “ntfsresize” error with the dropdown arrow causes GParted to hang indefinitely. Is there a log file I can attach for better explanation? And is this a disk issue? It should be known that Manjaro can in fact read the disk (“1.0TB Volume”) from File System and can access files from it (from my previous Windows installation), and yes am making sure to unmount it before attempting anything :slight_smile:

Edited: Also trying to “Save details” causes GParted to hang :frowning:

Any advice?

This of course depends on the system you have but for me i was having the same problem. I’m using manjaro on a HP Pavilion laptop and what i did was go into the HP boot menu (basically spam esc) and ran some quick tests. Then i restarted and tried again and iran the installer and it worked.

For these type of activities: First backup valuable data!

For a WIN7 partition you should:

  • first clean the partition with Win7 tools, ideally also run a defragmentation
  • shrink the partition with Win7 tools

Only, if this is not sufficient, then I would think about using GParted. GParted can shrink the partition, but you will need to restart Win7 afterwards to remedy (automatically) the modified cluster structure, no big deal but should be considered.