Installer failed to format root partition


I’m trying to install Manjaro on an EFI system that currently holds Windows 10 and Ubuntu on a two partition LVM group (/ and /home). I’d like to reuse my /home to keep gnome and app configs, as well as data, so my plan was to just format the root volume and mount existing /home and /boot/efi.

However, after setting the manual partitioning scheme on Calamares it blows me with an error (translating from Spanish):

Installer failed when formatting partition /dev/vant/root on drive ‘vant’
Create ext4 filesystem on partition /dev/vant/root
Job: clear filesystem from /dev/vant/root
Job: create ext4 filesystem on /dev/vant/root
Command: mkfs.ext4 -qF /dev/vant/root

I read around and it seems that I’m following all the checklist from the guide titled “Dual boot Manjaro and Windows”, I can’t include links in my post. Including Intel RST and Optane, but skipping all formatting steps and swap partition.

Any ideas? System info below:

$ inxi -Fza                                                                
  Kernel: 5.9.11-3-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=es_ES keytable=es 
  tz=Europe/Madrid misobasedir=manjaro misolabel=MANJARO_GNOME_202 quiet 
  systemd.show_status=1 driver=nonfree nouveau.modeset=0 i915.modeset=1 
  Desktop: GNOME 3.38.1 tk: GTK 3.24.23 wm: gnome-shell dm: GDM 3.38.2 
  Distro: Manjaro Linux 
  Type: Laptop System: Notebook product: N14xWU v: N/A serial: <filter> 
  Chassis: No Enclosure type: 10 serial: <filter> 
  Mobo: Notebook model: N14xWU serial: <filter> UEFI: American Megatrends 
  v: 1.05.02 date: 03/26/2018 
  ID-1: BAT0 charge: 35.0 Wh condition: 35.0/35.3 Wh (99%) volts: 13.0/11.4 
  model: Notebook BAT type: Li-ion serial: <filter> status: Full 
  Info: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 8E (142) stepping: A (10) 
  microcode: E0 L2 cache: 6144 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 28808 
  Speed: 700 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 702 2: 743 
  3: 740 4: 747 5: 782 6: 705 7: 797 8: 745 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel UHD Graphics 620 vendor: CLEVO/KAPOK driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:5917 
  Device-2: Chicony Chicony USB2.0 Camera type: USB driver: uvcvideo 
  bus ID: 1-4:3 chip ID: 04f2:b649 
  Display: wayland server: 1.20.10 compositor: gnome-shell 
  driver: i915 note: display driver n/a - try sudo/root display ID: 0 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.2.3 
  direct render: Yes 
  Device-1: Intel Sunrise Point-LP HD Audio vendor: CLEVO/KAPOK 
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus ID: 00:1f.3 
  chip ID: 8086:9d71 
  Sound Server: ALSA v: k5.9.11-3-MANJARO 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: CLEVO/KAPOK driver: r8169 v: kernel port: e000 bus ID: 3a:00.1 
  chip ID: 10ec:8168 
  IF: enp58s0f1 state: down mac: <filter> 
  Device-2: Intel Wireless-AC 9260 driver: iwlwifi v: kernel port: e000 
  bus ID: 3b:00.0 chip ID: 8086:2526 
  IF: wlp59s0 state: up mac: <filter> 
  Device-3: Intel Wireless-AC 9260 Bluetooth Adapter type: USB driver: btusb 
  bus ID: 1-5:4 chip ID: 8087:0025 
  Local Storage: total: 238.12 GiB used: 207.9 MiB (0.1%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 vendor: Kingston model: SA1000M8240G size: 223.57 GiB 
  block size: physical: 512 B logical: 512 B speed: 15.8 Gb/s lanes: 2 
  serial: <filter> rev: E8FK11.L scheme: GPT 
  ID-2: /dev/sda type: USB model: General USB Flash Disk size: 14.55 GiB 
  block size: physical: 512 B logical: 512 B serial: <filter> rev: 1100 
  scheme: MBR 
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
  ID-1: / raw size: N/A size: 11.64 GiB used: 207.9 MiB (1.7%) fs: overlay 
  source: ERR-102 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 49.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 275 Uptime: 29m Memory: 15.52 GiB used: 1.79 GiB (11.5%) 
  Init: systemd v: 246 Compilers: gcc: N/A Packages: pacman: 1246 lib: 321 
  flatpak: 0 Shell: Zsh v: 5.8 running in: gnome-terminal inxi: 3.1.08

$ LANG=C sudo parted -l                                                    
Model: General USB Flash Disk (scsi)
Disk /dev/sda: 15.6GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 2      2816MB  2820MB  4194kB  primary               esp

Model: KINGSTON SA1000M8240G (nvme)
Disk /dev/nvme0n1: 240GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system  Name                          Flags
 1      1049kB  538MB  537MB   fat32                                      boot, esp
 2      538MB   140GB  140GB                                              lvm
 3      140GB   140GB  16.8MB               Microsoft reserved partition  msftres
 4      140GB   240GB  99.4GB  ntfs         Basic data partition          msftdata
 5      240GB   240GB  545MB   ntfs                                       hidden, diag

$ LANG=C sudo efibootmgr -v                                                
BootCurrent: 0004
Timeout: 1 seconds
BootOrder: 0003,0004,0001,0000,0002
Boot0000* Windows Boot Manager	HD(1,GPT,2f85e27b-dc95-4e1d-a385-31823a572442,0x800,0x100000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}....................
Boot0001* ubuntu	HD(1,GPT,2f85e27b-dc95-4e1d-a385-31823a572442,0x800,0x100000)/File(\EFI\UBUNTU\SHIMX64.EFI)
Boot0002* Xen	VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)
Boot0003* UEFI: General USB Flash Disk 1100	PciRoot(0x0)/Pci(0x14,0x0)/USB(0,0)/CDROM(1,0x53e904,0x8000)..BO
Boot0004* UEFI: General USB Flash Disk 1100, Partition 1	PciRoot(0x0)/Pci(0x14,0x0)/USB(0,0)/HD(1,MBR,0x0,0x53e904,0x2000)..BO

$ test -d /sys/firmware/efi && echo efi || echo bios                       

Thanks a lot!

Welcome at the Manjaro forum, @esbaixauli :tada: :

Is Secure boot really switched off in firmware and Fast Startup in Windoze disabled, completely? Have you booted the USB stick in UEFI mode? It seems you have booted the MBR version. Manjaro comes as hybrid ISO, if not done then please select the UEFI version and try again.

Edit: Calamares is probably not able to help you to install the OS if you have a disk using LVM volumes.

Hi @Wollie! Thanks for your reply.

From the output of the last command I posted, I’d say I’m booting the efi version. And efibootmgr entries #3 and 4 also point in that direction, I tried booting them both with the same result.

Regarding LVM, Calamares actually lets me choose between two drives: my physical SSD and the volume group ‘vant’ inside it. I can choose a physical partition for /boot/efi and two logical volumes for / and /home. But I have no idea if that is actually supported or if there is a different way to proceed to achieve this.

Anyway, thank you and anyone who cares to answer :slight_smile: Any help is appreciated.


Hi again,

I tried manjaro-architect and it did format my root partition, so went back to Calamares and set the same partition scheme without formatting it again - it passed the step where it used to fail.

Now I have a different issue: Calamares now failed on grub-install:

Installing for x86_64-efi platform. grub-install: error: cannot find a device for /boot/grub (is /dev mounted?).

I checked and after the error both /dev (in the live system) and /tmp/calamares-root-[random-chars]/dev were mounted. I don’t recall exactly how the calamares-root-randomchars went, but it looked like the root of my new system. And I think that same root should be the device grub-install is failing to find, is it not?

I guess I have two options: try again tweaking the live system so that grub-install does not fail, or install grub manually (I’ve done it before, it should not be that hard), but then I’d have to do all of Calamares’ remaining work manually too. I don’t know which option might be the best.

Any ideas or recommendations?


Well, back here just to say that I solved everything by using Manjaro Architect. Everything worked just as expected both during install and after first boot. At first I thought the grub-install error from Calamares was solved by removing an efi entry from efibootmgr but it wasn’t really true, since I tried again several times and it only worked on the first one - no idea why.

So in case anyone finds any of these errors and can’t find the way around them - just use the Architect, it’s also included in the ISO you burnt.

Thank you everyone who read this topic!

1 Like