Installer crashes on Chromebook with any Manjaro installer

tl;dr I can’t install manjaro on my Chromebook

I recently resurrected an HP Chromebook 14 ‘falco’ with a new SSD. I’ve tried latest

  1. Manjaro Gnome graphical installer on two different install media
  2. Manjaro XFCE installer
  3. Manjaro Architect install media
  4. Manjaro Gnome install media but run Architect instead of Calmares

1 and 2: Both of these boot fine but at some point during the graphical install (Calmares?) they always crash, often to a black screen with a flashing cursor. If I try to log in on console I get an ‘account locked due to multiple failed authentication failures’ message immediately on the first attempt (using password and user ‘manjaro’).

3 Failed to boot on the Chromebook.

4 Booted happily as before but part way through the install it crashed as with the graphical install. I was able to log in on the console, but couldn’t see any obvious errors in journalctl.

The crashes happen at random points during the install.

I have been able to install:

  • Gallium OS (ubuntu based and aimed at chromebooks)
  • Garuda Linux (it ran happily for a couple of weeks)
  • Endeavor OS

There is a known problem with this Chromebook - it has memory errors (soldered on memory). I’ve been using the memmap kernel option to map around the bad bits. Both during install and in /etc/default/grub once installed.

That worked well in Garuda and Gallium. Endeavor required ‘add_efi_memmap’ in addition to the memmap address but also works.

I’m wondering if manjaro is silently ignoring the memmap and crashing because its hitting bad memory.

Does the manjaro install media kernel have memmap enabled?
And how can I work around this if not?

(Before its ssd died this chromebook was running manjaro for a couple of years. Because it worked so well I swapped ubuntu for manjaro on all the other computers in the house. So it’ll be a shame if I end up running a different distro only on the Chromebook.)

EDITED: I have Endeavor OS working now. It’s only manjaro installer that crashes.

1 Like

tl;dr Installed manjaro Gnome via manjaro Architect install media

Tried manjaro kde installer - crashes just as other manjaro gui installers.
I had another attempt with the manjaro Architect install media - this time it successfully booted.

I managed to install manjaro Gnome via architect - I’m posting this update from it :slight_smile:
Had to manually install glibc to get the grub installer to work but part from that it went well - albeit taking much longer than a graphical install.

I’ve added the kernel options “add_efi_memmap memmap=1K\$0x7768C” to grub config (did the same when running architect install media).

Everything seems to be working well, though I have yet to check whether the kernel is actually using memmap to reserve the bad memory…

Marking this solved.

EDIT: I needed to triple escape the $ in the grub kernel command, discourse is removing two of the slashes…

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.