Installer can't create partition


I’ve installed and removed linux mint 19.3 xfce before. I’ve deleted entire partition and grub from windows boot loader.
I’m trying to install latest manjaro gnome edition as dual boot to my lenovo thinkpad E14 gen1. Installer gives an error while creating partition table.
I’ve tried secureboot on and off, UEFI and BOTH options. Also I got same error at linux mint 20 install.

My partition table before install:
pasteboard .co/JIU9vAB.png
After Install:
pasteboard .co/JIU9Ewf.png
The error I got:
pasteboard .co/JIU9QOV.jpg

recheck all option in Bios to get only UEFI

disable secureboot
disable fastboot
no CSM or Legacy
choose UEFI only or first or others ( not windows )
disks on AHCI
no optane RST

and boot in UEFI only on USB iso
you should see this
UEFI < USB vendor name > < partition 1>

can you boot on USB iso manjaro
open a terminal and a browser on this topic
and returns

inxi -Fza
test -d /sys/firmware/efi && echo efi || echo bios
sudo parted -l
sudo efibootmgr -v

Hi I’ve deleted everything on ssd and tried to install but no luck.

    ~  inxi -Fza                                                        ✔ 
  Kernel: 5.9.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=tr tz=UTC 
  misobasedir=manjaro misolabel=MANJARO_GNOME_2021 quiet 
  systemd.show_status=1 driver=free nouveau.modeset=1 i915.modeset=1 
  Desktop: GNOME 3.38.2 tk: GTK 3.24.24 wm: gnome-shell dm: GDM 
  Distro: Manjaro Linux 
  Type: Laptop System: LENOVO product: 20RBS1L200 v: ThinkPad E14 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: LENOVO model: 20RBS1L200 serial: <filter> UEFI: LENOVO 
  v: R16ET28W (1.14 ) date: 09/14/2020 
  ID-1: BAT0 charge: 32.4 Wh condition: 45.0/45.0 Wh (100%) volts: 11.8/11.1 
  model: LGC 5B10W138 type: Li-poly serial: <filter> status: Discharging 
  cycles: 6 
  Info: Quad Core model: Intel Core i5-10210U bits: 64 type: MT MCP 
  arch: Kaby Lake note: check family: 6 model-id: 8E (142) stepping: C (12) 
  microcode: DE L2 cache: 6 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 33615 
  Speed: 900 MHz min/max: 400/4200 MHz Core speeds (MHz): 1: 900 2: 900 
  3: 900 4: 900 5: 900 6: 900 7: 900 8: 900 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
  Type: srbds mitigation: TSX disabled 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel UHD Graphics vendor: Lenovo driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:9b41 
  Device-2: IMC Networks Integrated Camera type: USB driver: uvcvideo 
  bus ID: 1-8:3 chip ID: 13d3:5415 
  Display: wayland server: 1.20.10 compositor: gnome-shell 
  driver: i915 note: n/a (using device driver) - try sudo/root display ID: 0 
  resolution: <missing: xdpyinfo> 
  OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 20.3.1 
  direct render: Yes 
  Device-1: Intel vendor: Lenovo driver: snd_hda_intel v: kernel 
  alternate: snd_soc_skl,snd_sof_pci bus ID: 00:1f.3 chip ID: 8086:02c8 
  Sound Server: ALSA v: k5.9.16-1-MANJARO 
  Device-1: Intel Wireless-AC 9462 driver: iwlwifi v: kernel port: 3000 
  bus ID: 00:14.3 chip ID: 8086:02f0 
  IF: wlp0s20f3 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Lenovo driver: r8169 v: kernel port: 2000 bus ID: 04:00.0 
  chip ID: 10ec:8168 
  IF: enp4s0 state: down mac: <filter> 
  Local Storage: total: 491.85 GiB used: 149.8 MiB (0.0%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: TeamGroup model: TM8FP6512G 
  size: 476.94 GiB block size: physical: 512 B logical: 512 B 
  speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: V1.0 temp: 47.9 C 
  ID-2: /dev/sda maj-min: 8:0 type: USB vendor: SanDisk model: Cruzer Glide 
  size: 14.91 GiB block size: physical: 512 B logical: 512 B 
  serial: <filter> rev: 1.27 
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
  ID-1: / raw size: N/A size: 11.59 GiB used: 149.8 MiB (1.3%) fs: overlay 
  source: ERR-102 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 45.0 C mobo: 0.0 C 
  Fan Speeds (RPM): cpu: 0 
  Processes: 270 Uptime: 3m wakeups: 3229 Memory: 15.45 GiB 
  used: 2.15 GiB (13.9%) Init: systemd v: 247 Compilers: gcc: N/A Packages: 
  pacman: 1285 lib: 368 flatpak: 0 Shell: Zsh v: 5.8 
  running in: gnome-terminal inxi: 3.2.01 
    ~  test -d /sys/firmware/efi && echo efi || echo bios               ✔ 
    ~  sudo parted -l                                                   ✔ 

We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.

[sudo] password for manjaro: 
Model: SanDisk Cruzer Glide (scsi)
Disk /dev/sda: 16.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 2      2954MB  2958MB  4194kB  primary               esp

Model: TEAM TM8FP6512G (nvme)
Disk /dev/nvme0n1: 512GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name  Flags
 1      1049kB  538MB   537MB   fat32              msftdata
 2      538MB   42.5GB  41.9GB

    ~  sudo efibootmgr -v                                        ✔  4s  
BootCurrent: 001F
Timeout: 0 seconds
BootOrder: 0000,0010,0011,0012,0013,0014,0018,0019,001A,001B,001C,001D,001E,001F,0020
Boot0000* manjaro	HD(4,MBR,0xc2a43cc,0x3b9d9800,0x5a34)/File(\EFI\manjaro\grubx64.efi)
Boot0010  Setup	FvFile(721c8b66-426c-4e86-8e99-3457c46ab0b9)
Boot0011  Boot Menu	FvFile(126a762d-5758-4fca-8531-201a7f57f850)
Boot0012  Diagnostic Splash Screen	FvFile(a7d8d9a6-6ab0-4aeb-ad9d-163e59a7a380)
Boot0013  Lenovo Diagnostics	FvFile(3f7e615b-0d45-4f80-88dc-26b234958560)
Boot0014  Regulatory Information	FvFile(478c92a0-2622-42b7-a65d-5894169e4d24)
Boot0015  Startup Interrupt Menu	FvFile(f46ee6f4-4785-43a3-923d-7f786c3c8479)
Boot0016  Rescue and Recovery	FvFile(665d3f60-ad3e-4cad-8e26-db46eee9f1b5)
Boot0017  MEBx Hot Key	FvFile(ac6fd56a-3d41-4efd-a1b9-870293811a28)
Boot0018* USB CD	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,86701296aa5a7848b66cd49dd3ba6a55)
Boot0019* USB FDD	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,6ff015a28830b543a8b8641009461e49)
Boot001A* NVMe0	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,001c199932d94c4eae9aa0b6e98eb8a400)
Boot001B* NVMe1	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,001c199932d94c4eae9aa0b6e98eb8a401)
Boot001C* ATA HDD0	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f600)
Boot001D* ATA HDD1	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f601)
Boot001E* ATA HDD2	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f602)
Boot001F* USB HDD	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,33e821aaaf33bc4789bd419f88c50803)
Boot0020* PXE BOOT	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,78a84aaf2b2afc4ea79cf5cc8f3d3803)
Boot0021* IDER BOOT CDROM	PciRoot(0x0)/Pci(0x14,0x0)/USB(11,1)
Boot0022* IDER BOOT Floppy	PciRoot(0x0)/Pci(0x14,0x0)/USB(11,0)
Boot0023* ATA HDD	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f6)
Boot0024* ATAPI CD	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,aea2090adfde214e8b3a5e471856a354)
    ~ 

boot on USB iso manjaro with Free Drivers
use (e)dit on Grub screen ,
use arrows
add on boot kernel “nvme_core.default_ps_max_latency_us=0”

before install launch Gparted
( if not present add sudo pacman -S gparted )

create partition
/boot/efi ( vfat - fat32 ) 100Mo
/ ext4 40Go
/home ext 4 all the rest

add flag boot & esp on /boot/efi

then lauch install , select manual ,add as mountpoint

1 Like

I followed the steps you provided. Gparted is also failed. :frowning:
I got two errors.
" 64-bit filesystem support is not enabled. The larger feilds afforded by this feature enable full-strength checksumming. Pass -0 64but to rectify. "

mkfs.Ext4 : error input/output while writing out and closing file system.

I also checked ssd with smart and badblocks it seems fine.

I’ve create partition table with an bootable partition wizard before I install manjaro. After that I just go with manual option to bind mounts. It successfully installed at the moment.