Installed spotify but it won't open

I installed Spotify using snap and the process seemed to complete normally and it shows up in my applications. However, when I try to open it won’t open and just doesn’t do anything. I just started using manjaro today so sorry if I’m doing a stupid mistake

Did you reboot your machine?

thanks for the tip, tried it but it still won’t open, i’ve tried reinstalling it a few times as well

In my experience, the snap takes forever to launch. I have sometimes launched it three times because I never saw any indication that it was running. IIRC, I finally discovered it was running via the task switcher. This is on Gnome, by the way. If you can get it to install successfully via AUR, it runs so much faster.

Hello and welcome to the forum!

I installed it from the AUR and it runs fine. Maybe an option for you, as @flibby.jibbit mentioned above. I am on KDE Plasma by the way.

Please launch spotify via the terminal and post the output.

I personally use spotify from AUR without issues.

I also use Spotify from AUR, works fine. Snaps or flatpaks are only if repo or AUR versions won’t work, which happens rarely. Normal packages (from repo and AUR) take less space and are snappier, so using snaps or flatpacks is a last resort in my opinion.

Can’t install spotify from AUR. I agree it runs faster than snap due to former XFCE installations.
Lately i get this message:
spotify-1.1.10.546-Release … Skipped
spotify-1.1.10.546-Release.sig … Skipped
==> Validating source_x86_64 files with sha512sums…
spotify-1.1.10.546-x86_64.deb … Passed
spotify-1.1.10.546-x86_64-Packages … Passed
==> Verifying source file signatures with gpg…
spotify-1.1.10.546-Release … FAILED
==> ERROR: One or more PGP signatures could not be verified!
Failed to build spotify

I can’t post a link but if you google the error in your post you will find a useful superuser link

You need to add the missing key to your database using gpg --recv-keys <missing key here>

Snaps come with many issues. They are intended to make developers lives easier but don’t do much for users at all.

1 Like

You can also import the missing key directly from their own repos:

curl -sS https://download.spotify.com/debian/pubkey.gpg | gpg --import -

Then simply install Spotify using Manjaro’s pamac:

pamac build spotify

That should work.

4 Likes

this worked for me after another restart, my computer had been unable to build the package but it finally works, thank you everyone for your advice

Thanks very much it worked !

Glad to hear it worked. Could you please mark the reply as a “solution” so future readers find it easily without having to scroll all the way to the bottom? Appreciated.

I tried installing Spotify from the official installation instructions page ( https://www.spotify.com/ro/download/linux/ ) with a snap URI. It installs successfully but when I try to run it I get:

$ spotify
Gtk-Message: 13:16:52.367: Failed to load module "canberra-gtk-module"
fish: 'spotify' terminated by signal SIGTRAP (Trace or breakpoint trap)

Now I try to install it from AUR.

Thank you!

Try this it worked for me.