Installed NVidia GPU Drivers with my AMD GPU System - How do I revert or fix

[jorogumo4@leo-x470aorusultragaming ~]$ screenfetch

 ██████████████████  ████████     jorogumo4@leo-x470aorusultragaming
 ██████████████████  ████████     OS: Manjaro 23.0.0 Uranos
 ██████████████████  ████████     Kernel: x86_64 Linux 6.1.41-1-MANJARO
 ██████████████████  ████████     Uptime: 2m
 ████████            ████████     Packages: 1308
 ████████  ████████  ████████     Shell: bash 5.1.16
 ████████  ████████  ████████     Resolution: 7680x1440
 ████████  ████████  ████████     DE: Xfce4
 ████████  ████████  ████████     WM: Xfwm4
 ████████  ████████  ████████     WM Theme: Matcha-sea
 ████████  ████████  ████████     GTK Theme: Matcha-dark-sea [GTK2]
 ████████  ████████  ████████     Icon Theme: Papirus-Maia
 ████████  ████████  ████████     Font: Noto Sans 10
 ████████  ████████  ████████     Disk: 438G / 953G (49%)
                                  CPU: AMD Ryzen 7 2700X Eight-Core @ 16x 3.7GHz
                                  GPU: NVIDIA GeForce RTX 2070
                                  RAM: 3086MiB / 48124MiB

It sounds stupid I know, but I repasted an old RTX 2070 of mine and wanted to make sure everything on it still worked. So I removed my AMD GPU and installed the RTX 2070. Turned on the PC and well, the desktop environment seems to have work, I don’t get my typical GUI but i get wallpapers and I can run everything I need from terminal. So I open steam and try to launch a game to make sure temps are good. Well, games won’t run. So I run the following command to install NVidia drivers for the 2070

sudo mhwd -a pci nonfree 0300

Rebooted and boom games work. Finished testing everything. Shut down my PC and reinstalled my AMD GPU. Well. Now my system posts, I see Manjaro loading screen, then just a blank screen. Monitors are on, but nothing comes up. The desktop enviornment is completely black.

Any ideas on how I can fix this? For the meantime I’m on the 2070 again.

mhwd -l -li
sudo mhwd -r pci video-nvidia

(or whatever profile you have installed)

sudo mhwd -f -i pci video-linux
[jorogumo4@leo-x470aorusultragaming ~]$ mhwd -l -li
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
          video-nvidia            2023.03.23               false            PCI
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!
> 0000:09:00.0 (0300:10de:1f07) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
          video-nvidia            2023.03.23               false            PCI
    video-nvidia-470xx            2023.03.23               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

So sudo mhwd -r pci video-nvidia would be what I need to run? followed by sudo mhwd -f -i pci video-linux?

Is it possible to leave the nvidia driver and just use video-linux?

You already did that.
You installed both profiles and your amd would not work while the nvidia profile was installed.
It should technically be possible - but mhwd puts in xorg files etc … so no, not without breaking the profile (in which case you would likely have to undo said changes again for nvidia to work … so it becomes rather pointless).

1 Like

Gotcha. I removed the video-nvidia profile and reinstalled video-linux as you put in the first post and rebooted with my AMD graphics card and everything is back to normal :slight_smile: Thank you so much!

Glad it worked out. Cheers. :slight_smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.