Installed Manjaro, it worked, but now won't boot anymore

Hi everyone, i’m new to Linux, so i need some help.

Yesterday I installed dual-boot Manjaro xfce on my Laptop (Dell Inspiron 5567).

Everything worked fine, except for a black error screen after the GRUB selection, but no big deal.

Today i decided to reinstall, switching to KDE Plasma for better HDPI scaling.

Everything installed correctly, i restarted, and everything booted up correctly (except for that same black error screen).

I proceeded to set up display settings, and rebooted to apply. It booted correctly (again, after that black error screen).

Then i installed some programs (chromium, visual studio code, gimp, inkscape, etc.).
I then noticed that when i opened Dolphin file manager, there was an error (“unable to create io–slave”, because it could not load some library of kio [or something like that]).

Basically it wouldn’t show any file. Therefore i decided to reboot to see if it solved the problem.

Now here’s the real problem: i rebooted, selected Manjaro on the grub, and got the same black error screen, but this time it would stop there. Usually it would go past that error very quickly and then boot.

Now it just stays on that error screen, and won’t boot.

Here’s the black error screen that i get everytime i boot (i transcribed it):

[    0.137371] mce: [Hardware Error]: CPU 0: Machine Check: 0 Bank 6: ee20000000
[    0.137375] mce: [Hardware Error]: TSC 0 ADDR fef1cbc0 MISC 43880014086
[    0.137379] mce: [Hardware Error]: PROCESSOR 0:806e9 TIME 1599678911 SOCKET 0
  APIC 0 microcode b4
[    0.1373831 mce: [Hardware Error]: CPU 0: Machine Check: 0 Bank 7: ee20000000
[    0.137385] mce: [Hardware Error]: TSC 0 ADDR fef1ce40 MISC 7880014086
[    0.137388] mce: [Hardware Error]: PROCESSOR 0:806e9 TIME 1599678911 SOCKET 0
  APIC 0 microcode b4

I dont’ know what any of this means, but why does this prevent boot now, when it didn’t before?
What can I try to do to fix this?

Thank you very much.

Welcome @MQ95 at the forum! :grinning:

Did you update before doing that or updated at the same time? First thing to do after a fresh install is updating!

Thanks for the answer!

No I did not. I figured i’d do it later.

I also got a message saying that the kernel in use wasn’t supported.

Would my best bet be to reinstall everything, update, and see if that works?

If you had kernel 5.6 from the iso, indeed you would have to change the kernel first as this isn’t supported any longer. Best is to check #announcements before updating.

Welcome to the forum! :slight_smile:

Well, you obviously have a hardware problem. One possible cause might be overheating, but that’s only one of the many possible causes.



Machine checks are a hardware problem, not a software problem. They are often the result of overclocking or overheating. In some cases, the CPU will shut itself off once passing a thermal limit to avoid permanent damage. But they can also be caused by bus errors introduced by other failing components, like memory or I/O devices. Possible causes include:

  • Poor CPU cooling due to a CPU heatsink and fan that’s clogged with dust or has come loose.
  • Overclocking beyond the highest clock rate at which the CPU is still reliable.
  • Failing motherboard.
  • Failing processor.
  • Failing memory.
  • Failing I/O controllers, on either the motherboard or separate cards.
  • Failing I/O devices.
  • Inadequate or failing power supply.
  • Poor general case cooling due to inadequate or clogged case fans or filters.

Cooling problems are usually obvious upon inspection. A failing motherboard or processor can be identified by swapping them with functioning parts. Memory can be checked by booting to a diagnostic tool, like memtest86. Non-essential failing I/O devices and controllers can be identified by unplugging them if possible or disabling the devices to see if the problem disappears. If the failures typically only occur fairly soon after the OS is booted or not at all or not for days, it may be suggestive of a power supply issue. With a power supply problem, the failure often occurs when power demand peaks as the OS starts up any external devices for use.

That’s really strange, since i’m posting from the same Laptop (i’m booting windows 10 with no problem at all). :man_shrugging:

Not necessarily a hardware issue, could be a bug. Try this:

1 Like

I think this might work, but I’m not able to do it from the GRUB command line.
It says “sudo” command not recognized.

Is there a way to add the parameters from GRUB?

I think there is an option to enter “e” to edit temporary the grub info usually located in the grub file.

Yes, i think I’m inside there.

It says:

"getparams 'Manjaro Linux'

       set gfxpayload=keep
       Etc etc etc a lot of stuff.

What do I write in there?

Is there a line starting with


If yes, add the parameters between the apostrophes somewhere and keep distance to the other parameters. Afterwards you need to save and exit (to boot).

It’s late here, I’m out for today. maybe someone else continues to help you. :bed:

1 Like

There is not, I tried adding the line and the parameters, but it didn’t work. Oh well…

Guess it’s time to reinstall from scratch.

But thank you very much Wollie!

EDIT: really strange!

I installed a fresh Manjaro, installed all the updates, rebooted a few times to make sure it was all right, and it worked.

Then i installed Chromium.
I opened Dolphin, and got the error message:

impossible to create io-slave. klauncher said : "error loading /usr/lib/qt/plugins/kf5/kio/"

Strange, the same error as before.

Then i rebooted to see if it would go away, and woah!

Manjaro bootloader started up, but my only boot option to choose from is Windows Boot Manager!
As if Manjaro suddenly disappeared.

Now I don’t know what to do anymore haha

couldn’t be that your installation is corrupt? Did you try a new installation (deleting old partition and creating new ones)? Did you great a boot partition?