Installed Manjaro in dual boot but Windows starts without GRUB

Hi fellow Manjaro lovers,

after years of not using Linux because I needed Windows for uni work I graduated which means I am also free to reinstall Manjaro.

So I installed the latest Manjaro Gnome in dual boot alongside Windows but when I restart my PC Windows boots straight away without I can have a chance to see GRUB.

Here is some clues on what the situation is:

> sudo parted -l                                                   ✔ 
Model: ATA SSDPR-CX400-512 (scsi)
Disk /dev/sda: 512GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 
Number  Start   End     Size    File system  Name                          Flags
 1      1049kB  17.8MB  16.8MB               Microsoft reserved partition  msftres
 2      17.8MB  403GB   403GB   ntfs         Basic data partition          msftdata
 4      403GB   511GB   108GB   ext4
 3      511GB   512GB   614MB   ntfs                                       hidden, diag
Model: ATA TOSHIBA MQ01ABF0 (scsi)
Disk /dev/sdb: 500GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 
Number  Start   End    Size   File system  Name                  Flags
 1      1049kB  556MB  555MB  ntfs         Basic data partition  hidden, diag
 2      556MB   661MB  105MB  fat32        EFI system partition  boot, esp
 3      661MB   500GB  499GB  ntfs         Basic data partition  msftdata
Model: SanDisk Cruzer Blade (scsi)
Disk /dev/sdc: 8004MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 
Number  Start   End     Size    Type     File system  Flags
 2      2783MB  2787MB  4194kB  primary               esp


> lsblk -f                                                         ✔ 
     squash 4.0                                                    0   100% /run/miso/
     squash 4.0                                                    0   100% /run/miso/
     squash 4.0                                                    0   100% /run/miso/
     squash 4.0                                                    0   100% /run/miso/
│    ntfs               26BE383ABE380539                                    
│    ntfs               C6ECF016ECF0028B                                    
     ext4   1.0         f94c4ae4-919b-47f8-8c8e-38db7e51cd39                
│    ntfs         Ripristino
│                       3EFEE52EFEE4DF61                                    
│    vfat   FAT32       56E9-5C30                                           
     ntfs         Data  8E605E3F605E2E69                                    
sdc  iso966 Jolie MANJARO_GNOME_2101
│                       2021-04-10-10-44-02-00                     0   100% /run/miso/
│    iso966 Jolie MANJARO_GNOME_2101
│                       2021-04-10-10-44-02-00                              
     vfat   FAT12 MISO_EFI

Please note that I am almost a noob in Linux and I can’t read terminal code, I need a step by step solution.

You need to change your /etc/default/grub file e.g. by

sudo nano /etc/default/grub

Make sure it has these lines (i.e. “menu” instead of “hidden”):



sudo update-grub

and reboot.

1 Like

I edited the file with nano. Then I pressed ctrl+X and then Y(check if I’ve done it correctly).
Then I receive the following error:

sudo update-grub
/usr/bin/grub-probe: error failed to get canonical path to ‘overlay’

Do you still have the USB stick connected with your live ISO? You need to do this from the “real” install not from within the live ISO boot.

When you change the grub file usually you are also asked for your password when you try to save the file…

Yes I booted via USB as I’ve done the fist time as I installed Manjaro.
Then I typed on terminal your commands, the USB stick was always connected.

As I said, you need to boot into the installed system from firmware, not the live ISO.

How do I access the installed Manjaro?

OK, now I understand. Then you have to chroot from live ISO:

Open a terminal window and enter

manjaro-chroot -a

(If entering 0 does not work, enter 1, password if needed is manjaro)

Then do what I described earlier.
Aferwards, don’t forget:


Afterwards, try to boot from firmware, hopefully the grub boot menu will appear.

I followed your instructions but it didn’t work.


[manjaro-gnome manjaro]# manjaro-chroot -a
grub-probe: error: cannot find a GRUB drive for /dev/sdc1. Check your
grub-probe: error: cannot find a GRUB drive for /dev/sdc1. Check your
==> Mounting (ManjaroLinux) [/dev/sda4]
→ mount: [/mnt]
[root@manjaro-gnome /]# sudo nano /etc/default/grub
[root@manjaro-gnome /]# sudo update-grub
Generating grub configuration file …
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.10-x86_64
Found initrd image: /boot/intel-ucode.img /boot/amd-ucode.img
Warning: os-prober will be executed to detect other bootable partitions.
It’s output will be used to detect bootable binaries on them and create new boot entries.
grub-probe: error: cannot find a GRUB drive for /dev/sdc1. Check your
grub-probe: error: cannot find a GRUB drive for /dev/sdc1. Check your
Adding boot menu entry for UEFI Firmware Settings …
Found memtest86+ image: /boot/memtest86+/memtest.bin

Try to boot the live ISO in UEFI mode, select the UEFI entry from your firmware, in case you installed Manjaro and Windows in UEFI mode, it’s not totally clear from your output. Windows and Manjaro must be installed in the same mode for a working dual boot.

Windows is installed in UEFI mode
How do I boot in UEFI mode?it is not clear

When you boot into your firmware, usually you can select the USB stick for boot. I would expect two entries, one starting with UEFI and one without. Select the one with UEFI in the name.

I see only one entry finishing with .efi that’s the one I use for UsB live boot

Yeah the same thing is happening with me it is detecting the windows efi partition and then when I exit it it says the manjaro partition which is automatically mounted while chroot is unmounted and the flags are gone again.

Would a full Manjaro(or other distro) installation solve the problem?

Sorry i might be late and I don’t about that but it was solved for me, i booted into the live usb installed gparted changed the flag of my efi partition to boot and esp which was legacy before for some reason.
Hope it helps.

Installing gparted :

sudo pacman -Syu

(the step below is to be done if u are experiencing a slow speed of internet)

sudo pacman -S pacman-mirrors
sudo pacman-mirrors --fasttrack 5 (the 5 means 5 lists)

(if you have a good speed then do this directly)

sudo pacman -S gparted (this will install gparted for you)

I do apologize in advance. I am actually trying to figure out a way to install Manjaro alongside my windows without installing grub. At the moment using Pop OS which does not install grub by default and you have to access Linux partition from the boot-menu which I actually really like. So i was wondering how to do the same with Manjaro.

Can you please tell me step by step how did you end up in such situation.

Thank You so much.

Hello, I am also having the issue where I’ve installed Manjaro alongside Windows and it is booting directly into Windows.

I have a Dell laptop with Windows 10. I have been trying all day to install Manjaro KDE alongside, but having issues. I got it installed, but then the computer just boots straight to Windows. I performed a fresh install of Windows and then another fresh install of Manjaro, and again it seems to have installed fine, but the system still just boots to Windows 10.

I have had other distros on this computer previously (Ubuntu & Mint, and an older version of Manjaro at one point) but I had to reinstall Windows over them for work. Now I’d like to dual boot Manjaro, but I’ve never run into an issue like this before.

I’ve got some experience with Linux, but I still consider myself a novice, so please let me know what info you need. Thanks in advance!

Actually I figured this out, it was right in front of my face the whole time…

I automatically chose “USB Storage Device” from the boot menu, which I now see is under the header “Legacy Boot”

There is a second option under “UEFI Boot” for “Generic Flash Disk” that is also the Live USB Install media.


I previously installed from the USB media while it was booted under the Legacy Boot header. I fixed it by reinstalling from the USB media booted up under the UEFI Boot header.

I realize the user manual makes it pretty clear that you need to make this distinction, I just didn’t realize my boot menu worked like that.

Anyway, rookie mistake! Hope this helps others who run into this issue!!

1 Like