Installed Manjaro alongside Windows 7 restarted and no bootloader option visible

I installed Manjaro from a live USB. I did the restart now option after it finished. Once it shut down and hit the MB landing screen I removed the flash drive. The computer booted to Windows 7 directly. It didn’t give me any option to select the Manjaro I just installed. I’ve restarted the computer a few times and looked at the boot menu and couldn’t find a linux bootloader anywhere.

How do I get into Manjaro, and how do I get the dual boot working correctly?

How did you install Windows / Manjaro - UEFI / BIOS?

It’s been a Windows 7 machine for a long time.

I ran the USB live and then installed it from there. I followed the dual-booting with windows 10 instructions from the user guide (p.43)

Hi!
You need to choose in bios to boot with the manjaro drive

I guess this is the culprit, your Windows is most likely installed in BIOS mode.

As the Manjaro ISO’s are of hybrid design, you need to select the BIOS entry from firmware (that’s the one without UEFI in the front of the name).

Most likely your disk is also msdos parted with MBR, which means the bootloader must then be placed in the MBR. If you have only one disk /dev/sda for example, the location for the grub boot loader is /dev/sda as well. No efi partition needed.

how do I confirm that? it looks like the bios is set up as UEFI

Start the live ISO again and open a terminal window, enter

sudo parted -l
sudo efibootmgr -v
lsblk -f

{Password is manjaro}

and post the result here. Please, use </> button in the forum editor to format the text.

Also, check your firmware settings for all settings with wording legacy, UEFI, CSM, BIOS.

indent preformatted text by 4 spaces[manjaro@manjaro ~]$ sudo parted -l

Model: ATA WDC WD20EFRX-68E (scsi)
Disk /dev/sda: 2000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 106MB 105MB fat32 EFI system partition boot, esp
2 106MB 240MB 134MB Microsoft reserved partition msftres
3 240MB 951GB 951GB ntfs Basic data partition msftdata
4 951GB 2000GB 1049GB ext4 boot, esp

Model: USB Flash Disk (scsi)
Disk /dev/sdb: 8179MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
2 3120MB 3124MB 4194kB primary esp

[manjaro@manjaro ~]$ sudo efibootmgr -v
EFI variables are not supported on this system.
[manjaro@manjaro ~]$ lsblk -f
NAME FSTYPE FSVER LABEL UUID FSAVAIL FSUSE% MOUNTPOINT
loop0 squashfs 4.0 0 100% /run/miso/sfs/livefs
loop1 squashfs 4.0 0 100% /run/miso/sfs/mhwdfs
loop2 squashfs 4.0 0 100% /run/miso/sfs/desktopfs
loop3 squashfs 4.0 0 100% /run/miso/sfs/rootfs
sda
├─sda1 vfat FAT32 CEDB-33D9
├─sda2
├─sda3 ntfs A010DF3B10DF16DE
└─sda4 ext4 1.0 d39d0ec0-6816-42f3-a3b9-321ceb59a1c5
sdb iso9660 Joliet Extension MANJARO_KDE_2003 2020-06-06-08-14-33-00
├─sdb1 iso9660 Joliet Extension MANJARO_KDE_2003 2020-06-06-08-14-33-00 0 100% /run/miso/bootmnt
└─sdb2 vfat FAT12 MISO_EFI F327-8F27
sr0
[manjaro@manjaro ~]$

how/where do I check the firmware settings?

Firmware settings means settings in your UEFI bios.

Good news is that you have a gpt parted disk and Windows installed in UEFI. But Manjaro was installed not properly, as no EFI variables are supported. Do you remember what you set for the location of the boot loader when installing Manjaro? Did you boot the USB stick with the UEFI entry?

In combination with your efi partition size is this not ideal. For a disk with a physical sector size of 4K your efi partition is smaller than recommended - it should be at least 260 MiB or better 300 MiB. You could alternatively to using the same efi partition for Windows and Manjaro create a separate efi partition just for Manjaro (I would choose 300 Mib size) and select this for Manjaro druing install process.

1 Like

I followed the defaults on the install screen. I can go in and check by trying to install it all over again to find it. I didn’t notice multiple entries in the boot option when I selected. I can also try that again.

How do I look at/select the sector size? Why do I want a larger sector size?

I opened the installer again from the live USB, and it doesn’t look like it give me an option of where to set the boot loader.

This is not ideal, for a disk with sector size of 4K your efi partition is smaller than recommendable it should be at least 265 MiB or better 300 MiB. In your case I would create a new efi partition for Manjaro and not use the existing one. After successfull installation you need to go into your firmware and set the Manjaro efi partition as the one to be booted from.

FAT32 requires min. 65,527 clusters, for 4096B this means ~ 262 MiB.

1 Like

I restarted the system and found the UEFI option for the live USB. I then installed manjaro again replacing the previous manjaro partition. It appears to be working now after the first restart. I’ll try a few more times to make sure.

Glad to hear that!

Enter bios and double click over boot manager to select Linux boot manager.

this partition /dev/sda4 has no need of boot & esp it ok for sda1