Installed Awesome ISO, Ran System Update (900 Packages), Display Now Improperly Cropped

I installed Manjaro’s Community Awesome Edition. The ISO is Manjaro 20, so there was a massive package update.

Before the update, the display looked normal. Now it’s weirdly cropped. The entire desktop appears as expected, but when I open window, the tiles only cover the upper left portion of the screen to about 80 percent at the bottom right. The rest of the rightmost and bottommost windows are cropped off. They’re there, but I can’t see them or interact with them.

I’ve tried changing resolutions to no effect.

The login screen looks perfectly normal, so it’s something specific to awesomewm.

I’ve just installed it and never used it. Is there a way I can force it to reset itself?


:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    How to provide good information
    and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies…

  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information… (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.

  3. Does this also happen when you create a new user and log in there? (E.G. johntdavis84-2)


@Fabby ,

Good afternoon! Thanks for your message, and the very helpful instructions. :slight_smile:

I’ve gathered the information you requested, but I wanted to sort out with the easy question:

Does this also happen when you create a new user and log in there?

Things appear to work as expected when creating a new user. Everything looks normal with the second user I created, except for a missing icon for the Power Manager widget. It’s just a little generic document icon with a folded lower-right corner. It still works when I click on it.

Thanks for the tip to try this. I was too busy stressing out over the weird behavior to remember that creating a new user fixed the graphics glitches the last time things went wrong after a system update. :slight_smile:

So, that appeared to fix the problem (the widget glitch likely being something else?), but I’m a bit concerned something still might be misconfigured. I’ve included my system info below. For context, I’m running Manjaro Awesome on a NAS equipped with a virtualization server, set to use 2 cores and 6 GB of RAM.

Requested information.
  Kernel: 5.11.6-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.11-x86_64 
  root=UUID=b989b1d8-4837-4d16-83dd-dc2e8ef05c29 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Console: tty pts/2 DM: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux 
  Type: Kvm Mobo: QEMU model: Standard PC (i440FX + PIIX, 1996) 
  v: pc-i440fx-4.1 serial: N/A UEFI: N/A v: N/A date: N/A 
  RAM: total: 5.8 GiB used: 1.27 GiB (22.0%) 
  Array-1: capacity: 6 GiB slots: 1 EC: Multi-bit ECC max-module-size: 6 GiB 
  note: est. 
  Device-1: DIMM 0 size: 6 GiB speed: type: RAM detail: other 
  bus-width: Unknown total: Unknown manufacturer: QEMU part-no: Not Specified 
  serial: <filter> 
  Info: Dual Core model: Intel Celeron J4125 bits: 64 type: MCP 
  arch: Goldmont Plus family: 6 model-id: 7A (122) stepping: 8 microcode: 1 
  cache: L2: 16 MiB bogomips: 7990 
  Speed: 1997 MHz min/max: N/A base/boost: 2000/2000 Core speeds (MHz): 
  1: 1997 2: 1997 
  Flags: 3dnowprefetch aes apic arat arch_capabilities arch_perfmon clflush 
  clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de erms fpu fsgsbase 
  fxsr ht hypervisor ibpb ibrs lahf_lm lm mca mce mmx movbe mpx msr mtrr nopl 
  nx pae pat pclmulqdq pdpe1gb pge pni popcnt pse pse36 pti rdrand rdseed 
  rdtscp rep_good sep sha_ni smap smep ss sse sse2 sse4_1 sse4_2 ssse3 syscall 
  tsc tsc_adjust tsc_deadline_timer tsc_known_freq vme x2apic xgetbv1 xsave 
  xsavec xsaveopt xsaves xtopology 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass status: Vulnerable 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: vendor: Red Hat driver: bochs-drm v: N/A alternate: bochs_drm 
  bus-ID: 00:02.0 chip-ID: 1234:1111 class-ID: 0300 
  Display: server: 1.20.10 compositor: compton driver: 
  loaded: modesetting alternate: fbdev,vesa tty: 255x63 
  Message: Advanced graphics data unavailable in console for root. 
  Device-1: Intel 82801FB/FBM/FR/FW/FRW High Definition Audio 
  vendor: Red Hat QEMU Virtual Machine driver: snd_hda_intel v: kernel 
  bus-ID: 00:04.0 chip-ID: 8086:2668 class-ID: 0403 
  Sound Server-1: ALSA v: k5.11.6-1-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.23 running: yes 
  Device-1: Intel 82371AB/EB/MB PIIX4 ACPI 
  vendor: Red Hat Qemu virtual machine type: network bridge 
  driver: piix4_smbus v: N/A modules: i2c_piix4 port: c100 bus-ID: 00:01.3 
  chip-ID: 8086:7113 class-ID: 0680 
  Device-2: Red Hat Virtio network driver: virtio-pci v: 1 modules: virtio_pci 
  port: c0e0 bus-ID: 00:03.0 chip-ID: 1af4:1000 class-ID: 0200 
  IF: ens3 state: up speed: -1 duplex: unknown mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: dynamic noprefixroute scope: global 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Message: No Bluetooth data was found. 
  Message: No LVM data was found. 
  Message: No RAID data was found. 
  Local Storage: total: 48 GiB used: 8.24 GiB (17.2%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/vda maj-min: 254:0 model: N/A size: 48 GiB block-size: 
  physical: 512 B logical: 512 B speed: <unknown> serial: N/A scheme: GPT 
  Optical-1: /dev/sr0 vendor: QEMU model: QEMU DVD-ROM rev: 2.5+ 
  dev-links: cdrom 
  Features: speed: 4 multisession: yes audio: yes dvd: yes rw: none 
  state: running 
  ID-1: / raw-size: 47.7 GiB size: 46.7 GiB (97.91%) used: 8.24 GiB (17.7%) 
  fs: ext4 block-size: 4096 B dev: /dev/vda2 maj-min: 254:2 label: N/A 
  uuid: b989b1d8-4837-4d16-83dd-dc2e8ef05c29 
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 292 KiB (0.1%) fs: vfat block-size: 512 B dev: /dev/vda1 
  maj-min: 254:1 label: N/A uuid: B26A-A869 
  Alert: No Swap data was found. 
  Message: No Unmounted partitions found. 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 6 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 1-1:2 info: Adomax QEMU USB Tablet type: HID 
  driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 480 Mb/s 
  power: 100mA chip-ID: 0627:0001 class-ID: 0300 serial: <filter> 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.0 speed: 5 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Message: No sensors data was found. Is sensors configured? 
  Processes: 150 Uptime: 25m wakeups: 613 Init: systemd v: 247 tool: systemctl 
  Compilers: gcc: 10.2.0 Packages: pacman: 1163 lib: 368 flatpak: 0 
  Shell: Zsh (sudo) v: 5.8 default: Bash v: 5.1.0 running-in: tty pts/2 (SSH) 
  inxi: 3.3.03 

Now that things are mostly working, what should I do to try to fix the glitch with the widget icons?

Related Question.

So, even though this appears to be fixed, I’m still a bit concerned.

The ISO for the Awesome WM edition of Manjaro is at 20.0. I upgraded it with pacman, but I’m wondering if upgrading 900 packages at once might have caused issues. Would it be better to start with a minimal image (if such thing exists) that does not have any GUI at all, and install Xorg and my preferred WM/DEs on that?

Or should I consider this fixed?

Thanks again!

No: Manjaro is a rolling release, and the ISOs only get refreshed 3-4 times / year.

Now that you’ve created an additional user and the problem seems to be gone there, there is still some clean-up required and therefore, we’re going to do the following:

  • Verify that the new user has access to the same groups as your old one by executing groups and comparing the output of both users.

    groups johntdavis84
    groups johntdavis84-2

    (Where obviously, johntdavis84 is your old user and johntdavis84-2 is your new one.)
    E.G. if johntdavis84 is a member of operator and johntdavis84-2 isn’t, execute:

    usermod --append --groups operator johntdavis84-2
  • Copy all data files from your old profile into your new one

    cp --verbose --recursive --preserve=time-stamps /home/johntdavis84/Documents/* /home/johntdavis84-2/Documents/

    If that worked and you had no errors, remove the documents from your old user:

    rm --recursive /home/johntdavis84/Documents/*

    repeat for:

    • Pictures
    • Videos
    • Music
    • .thunderbird
    • .mozilla/firefox/
    • Templates, and everything else that is important to you.
    • Linux games like Battle of Wesnoth have their game data stored under ~/.local/share/ E.G. ~/.local/share/wesnoth/

    After everything has been copied over, disable the old user so you cannot accidentally log on:

    usermod --lock johntdavis84

    If you would have theming going on, don’t do everything in one day but do this at the rate of 1 application / theme / whatever per day and if the problem crops up again, roll back your last change

  • in 1 month delete the entire home directory of your old user, but don’t delete the user itself so that in 6 months time files still owned by that user will still show up under its username.

  • If you ever migrate to a new machine, just don’t migrate the old user: only the new one.

  • From now on, start making backups so you can roll back and never have to do this again:


P.S. One last thing you could do is to ensure you’re on a Long Time Support (LTS) kernel and stay on a LTS kernel for stability reasons so I’d advise you to install both 5.4 LTS and 5.10 LTS and get rid of 5.11 after you’ve tested both 5.4 and 5.10 and it still works.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.