Installed AUR apps wont show up in the app menu

So I’ve been running into issues. When successfully installing AUR packages I can open the apps as long as I search for them via the search function but those installed packages won’t create an icon in the application menu. Do any of you guys ran into the same issue?

try this:

sudo update-mime-database /usr/share/mime
sudo update-desktop-database
1 Like

What installed packages?

unfortunately that didn’t help.

Discord, 1Password. I can launch them via search but they won’t create that icon in the application menu with is unfortunate :confused:

If they appear searching, they are in the menu. Maybe they’re in a folder?

Just to be sure, are you talking about the default app grid by pressing Super twice or Super+A, or are you using Arc Menu?

1 Like

May I assume when you successfully find them via search box you are then right-clicking on the program shown and the “Add to Favorites” and/or other options (e.g., Add to Panel, Desktop, Pin to Task Mgr…) are either not shown or not serving their intended purpose?

yes, I’m talking about that menu.

I installed Discord and it appeared there. I then added it to my favourites just to see that the icon won’t be shown again in the app grid after 5 minutes.

EDIT: okay, when I remove them from the dock they will be shown in the app grid again. But I’m used to add them to the dock plus be able to see them in the app grid. I just right click on them and chose “add to favourites” but even then they will be removed from the app grid.

Favorite applications do not appear in the app menu by default.

1 Like

Uhm okay? I’m used to it when I was using Ubuntu. So what’s the best way to have the icons in both the app grid and the dock?

When the app grid is open, the dock is visible. GNOME devs apparently think having them in both places is redundant.

one workaround would be use another dock so that you can have applications visible in both places

1 Like

You can try this extension.