Installation wizard is waiting for a module for a while

I would like to install the current software on another storage device.
Thus I started my computer from the file “manjaro-kde-21.0.7-210614-linux510.iso” by the means of the boot system “Ventoy 1.0.50”.
Now I wonder why the installation tool presents unexpected behaviour on the first wizard page.

[manjaro@manjaro ~]$ sudo calamares --debug
20:21:02 [6]: Calamares::Settings::Settings(const QString&, bool)
    Using Calamares settings file at "/etc/calamares/settings.conf" 
WARNING:     ..  Required settings.conf key hide-back-and-next-during-exec is missing. 
20:21:02 [6]: void Logger::setupLogfile()
    Using log file: "/root/.cache/calamares/session.log" 
20:21:02 [6]: void CalamaresApplication::init()
    Calamares version: 3.2.40-2 
20:21:04 [6]: Calamares::RequirementsList GeneralRequirements::checkRequirements()
     enoughStorage :   true 
     enoughRam :   true 
20:21:04 [6]: void Calamares::RequirementsChecker::addCheckedRequirements(Calamares::Module*)
    Got 5 requirement results from "welcome" 
20:21:05 [6]: void Calamares::RequirementsChecker::reportProgress()
    Remaining modules: 1 

Can any more improvements be achieved for the affected software aspects?

Does your internal disk use LVM?

1 Like

Yes. - I am using logical volume management for my storage devices for some years.
:thinking: Should the tool “calamares” handle the involved partitions for further installation attempts?

I have very little experience with LVM itself but has been doing some playaround with various pen-testing distributions.

Kali Linux is setting up LVM and when I tried to replace Kali with a customized Manjaro (tried combining Manjaro with BlackArch repo - don’t replicate - it is a pain) it noted the Calamares installler hanging for a long time seemed like indefinite.

Now that is some time ago - and my memory is not what it used to be. From time to time the topic is brought up and it may have been solved - but from your topic it appears Calamares is not there yet.

If I recall this correct when Calamares finally loaded it displayed two disks which was easily mistaken - the one being the LVM - the other being the physical disk.

I was waiting on the graphical user interface for a while so that the installation tool would let me configure the partitions for my needs.

:thinking: Would you like to point any development repositories out which would be helpful for testing the software behaviour of installation tool versions in more detailed ways?

How do you think about to take another look at the collaboration with the KDE partition manager core library? :thinking:

Would you like to discuss any execution durations according to software tools like the following?

  1. blockdev
  2. lsblk
  3. lvm
  4. sfdisk
  5. smartctl
  6. udevadm

Disconnect your harddisk, get a new one and don’t use LVM. It is not well supported when using Calamares as installer.

I did this occasionally before.

This happened for the reported software installation attempt.

I do not like this suggestion.

Would you like to reconsider data processing algorithms (according to the implementation in the function “FileSystem::detectMountPoint for example)? :thinking: