Installation Problem on Thinkpad X13 G3 A

I have been using Manjaro XFCE for quite a while on an Thinkpad X270 without major issues. Yesterday I got my new X13 Gen2 AMD and installed a Lexar 4TB nvme SSD. I first installed Win10 without problems, then I wanted to add Manjaro with Manual partition. BEfore I increades EFI system partition to 1GB. Unfortunately Manjaro didn’t boot. At the end I deleted Win10 and let the Manjaro installer reformat the drive and it still does not worl . Grub seems not to start and I get a Message : Error: Device ÙUID…`not found. Skipping fs … end end up in an emergency shell. I already found the recommendation to set the UEFI to AHCI istead of RAID but unfortunately do not have this option. I am quite desperate. Any ideas? Any help much appreciated. Thanks in advance.

  1. Grub is hidden by default. Press ESC when booting.
  2. The error is from the kernel. Problem could be:
    1. NVME not ready, takes longer than assumed to warm up.
    2. UUID is wrong.
    3. I would consider the point 1.

A quick search gave me this: 217863 – Lexar NM790 SSDs are not recognized anymore after 6.1.50 LTS Looks like a timeout issue. Probably kernel 6.5 has the fix now.


thanks a loot for the instant and helpful reply. The mentioned type Lexar 790 is exactly the one I have and after reading this my findings make sense. I tested the Manjaro on another 512 GB SSD which was shipped with the Laptop and here it worked. I also tried with Linux Mint (probably an older kernel) and this also worked fine. So I have to make up my mind if I wait until the patched kernel arrives at Manjaro (any ideas when this might happen) or I return the Lexar SSD and go for another one. When the SSD needs significantly more time to wake up it doesn’t give a good feeling to me and maybe I run into other problems in the future.

Thanks a lot and kind regards, Juergen