Installation on an Odroid HC4

I got my hands on an Odroid HC4 to play around a bit, so I decided to try Manjaro ARM. I flash the MicroSD using manjaro-arm-installer, put the card into the board and booted. To my surprise after booting from the card there was no video output at all, but apparently the system booted. I changed vt and hit ctrl-alt-del and the board rebooted.

In the Armbian documentation they say you must erase petitboot for it to boot any recent kernel, so I tried that for Manjaro. To clear petitboot:

  1. Select “Exit to shell”
  2. Execute the following commands:
# flash_eraseall /dev/mtd0
# flash_eraseall /dev/mtd1
# flash_eraseall /dev/mtd2
# flash_eraseall /dev/mtd3
  1. Reboot

After that Manjaro booted as expected (with video output).

Hope this helps others.

Edit: I selected Odroid C4 as target in manjaro-arm-installer.



Thanks a lot to Glock24 !

@Strit will be this device, Odroid HC4, in the Manjaro ARM devices ?

1 Like

The DTB for the HC4 is not yet in mainline kernel. When it does get there, we might look into adding this device.

So, @Glock24 , if you run inxi -M you will notice that it’s booted as an “Odroid C4” and not an Odroid HC4.
Most of the hardware is the same in those devices, so most will work fine.


Everything works except the most important feature of the HC4 which is the SATA controller. Any disk connected to the SATA ports is not detected, I haven’t found a way to make it work.

On a side note 3D acceleration seems to work fine using mesa-git and the linux-rc kernel. I tested just basic games though, supertux and chromuim-bsu.

With the default kernel and mesa package chromium-bsu just showed a black screen, after installing linux-rc and mesa-git it displays correctly and gives around 55fps.


I just noticed that reboot doesn’t work, I’m not sure if the board powers down or just freezes as the screen turns black.

Is your hdmi device outpout connect with a screen ?

Sometime the reboot doesn’t work after a kernel up date, with the command line interface or the graphic user interface…

unplug the power supply and plug it again to restart the device…

I’ve asked odroid for sample but didn’t get any response from the admin.
Looks like they’re not interested in sending sample to manjaro Arm project. :frowning:

Looks like a missing config in Kernel for the PCIE to Sata controller.

Will be receiving my device soon this week so I can test it myself and update the required changes.

Thank you for reporting.

1 Like

5.12 added the device tree for Odroid HC4, so it should soon be easier to get going. :slight_smile:

The reason why the SATA port does not work, is that the DTS used in your test, is based on a board, that does not have a SATA port.

1 Like

Tried linux-vim with HC4 and it worked fine with PCI_MESON enabled I have HDD visible in my test image.

Pushing linux-vim-5.11.4 and hc4 support packages to unstable now.

Next I need to look at LED and Fan support.

1 Like

Here is the unstable release.

1 Like

I used Manjaro-ARM-minimal-hc4-21.03-alpha-unstable.img.xz and as long as I do not update linux-vim, I could boot up from SSD snd microSDRAM. The image’s boot.init has to be modified as “load mmc ${devno}:1 ${dtb_loadaddr} /dtbs/amlogic/meson-sm1-odroid-hc4.dtb”.

I also found out by using “manjaro-arm-installer”, you could generate an image and boot it from microSDRam only, also this image will die randomly. But if I update this image with “linux-vim”, it seems to run smoothly, except has the same problem of directly booting using SSD.

Any suggestions will be much appreciated. Thanks.

1 Like


Ok so we need to add this to boot so we can boot from the ssd.

Thank you for the advice.