Installation from USB just does not start/ 21.07

I try to install Manjaro 21.07 from USB in paralel with already existing Windows10.
I created bootable USB using Rufus, started laptop from the stick, got the first initial screen. I select free drivers [or non-free - it does not matter] screen goes blank and nothing happens. I left laptop for 20min [walking my dog] and no progress.
I tried KDE, Gnome, XFCE - same story. Could somebody help me to troubleshoot this problem?
Thank you.

As you can’t even boot Manjaro, that’s a hard problem to diagnose so could you:

  1. Download a slightly older version as you might be running into a kernel bug?
  2. verify any one of the ISO hashes (SHA1 / SHA256 / … ) of the .iso you download (whichever you have available on your Windows install) before burning and booting that?
  3. If you do get it to boot, please provide an inxi --admin --verbosity=7 --filter --no-host --width as that would be the minimum required information… (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
  4. If you do not, please feed back.


The Rufus developer only begrudgingly sometimes bothers to support Manjaro ISOs. Perhaps try Ventoy or Etcher:

1 Like

Apologies for late reposnse, it worked with Ventoy. Now I have some issues in starting the system in a regular way [it starts with ‘fallback’ option, whatever that means] but I will search for solution.
Thank Yochanan :slight_smile:

That would be a totally different question, so please create one after reading this:


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.