Installation from fresh build-iso build fails on mkinitcpio with calamares 23.1.0 Vulcan installer

to reproduce the error:
just clone the repo:
git clone ~/iso-profiles

and do a fresh build (without changing anything in iso-profiles folder):
buildiso -f -v -b stable -p xfce

here you can find the full errorlog:

could anyone please help me on this or guide me to the correct forum bugtracker?
kind regards, Michael

Which version of the tools you are using? Currently only works with the latest commits of which there is no release yet.

manjaro-tools-base-git r3016.263d640-1

should I build from src?

You can simply download 23.1 official XFCE ISO which reflects the current stable branch state.

so buildiso is broken at the moment?
I need a custom build, so I will try to get help here:

or do you have a recommendation for me?

You can simply use the PKGBUILD and update it to latest master commit.

The simple method to get latest version of the toolbox.

git clone
cd manjaro-tools
sudo make install

Because /usr/local/bin is first in PATH it will override the package installed.

It appears you are building using linux54 - and the mkinitcpio fails building the init image.

Hello Linux-aarhus,
thx for the clear instructions! :slight_smile:
I made a new build of the tools, and tested the iso in my virtualbox.
But I got the same error… :frowning:

what I do not understand is, there is no error in the Log, only warnings…

Your usage of linux54 may be the reason why you are having an issue.

I just tested linux54 vs linux61 - first fails during install - linux61 doesn’t.

Hello Linux-aarhus and philm,
thx a lot!!
I changed my build to linux61, now it works again!! :slight_smile:
Kind regards,
you are great guys!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.