Installation fails with unpacking the image file rootfs.sfs


I am new to Manjaro, but have been using Linux (only) for 25 years now. I just got a new PC with a Ryzen 9 7940HS and decided to install Manjaro on it. I got the ISO from the official sources. All installation trials end with the following error:

message: "Entpacken der Abbilddatei \"/run/miso/bootmnt/manjaro/x86_64/rootfs.sfs\" fehlgeschlagen" 
details: rsync fehlgeschlagen mit Fehlercode 10.type or paste code here

A full log is here: termbin dot com slash aaeo

Secure boot is disabled in BIOS settings.

This is what I have done so far:
Copied the ISO to two different USB sticks with

  • various “bootable usb stick creator tools” for Linux (Ubuntu, etc.)
  • used ventoy
  • installed via sudo dd bs=4M if=./manjaro-kde-23.0.1-230911-linux65.iso of=/dev/sdc status=progress oflag=sync

I have downloaded the ISO three times, always checking the SHA512 hash keys.

What is happening:
In all cases I can boot into Manjaro via USB stick and start installation procedure. When I finally start installation, it creates the partitions and then suddenly stops with the above error.

I want to have seperate root and home partitions. My partitions are:
/boot/efi - fat32 - 512MB
/ - ext4 - 100GB
swap - swap - 32GB
/home - ext4 - 900GB

I tried it now 10 times with various settings, installations/USB sticks/etc. Nothing works.

But: If I install Manjaro using the suggested partitioning from Manjaro, I just found out it works. However, I do not want a huge partition with all on it, and it seems there is no swap partition (???)

Suggestion from Manjaro:
fat32 /boot/efi 300MB
ext4 root / 930GB

Can anyone please provide me some help or has anyone an idea how to solve this? Thank you so much!


Even if your checksum is correct - your target device may have errors.

rsync throws errors when the copied file does match source === destination.

I recommend checking the flashdrive with f3 in the manjaro repo.

For swap You can

  • no swap
  • swap - no hibernate
  • swap - with hibernate
1 Like

Hi, and thank you!

I have tried various USB sticks that all work. I have tested the NVMe drive with smartctl - no errors. And installation with suggested partitions worked.

I have now tried it again building on the partitions from the installerb(that basically just had a smaller /boot/efi partition …), but seperating / and /home and creating a swap snd this time it worked.

1 Like

Do you formatted the destination drive before installation ?

Hi, yes, I always do :slight_smile:

It is a clean installation, and I always (re-)format all partitions (except /home in case I upgrade the system …). In this case, I have formatted everything 10 times with each try …

Can you try another USB stick ?