Installation fails with Boot Loader Return Code 1


I wanted to install Manjaro xfce on a new old machine with Intel J1900 (GA-IMB1900TN). However the setup fails with the installation of the boot loader in /boot/efi and retunr code 1. I’ve tried it 3 times and it’s always the same.

So I just tried a Windows (Windows 10 Pro 21H2) and it installs and boots fine. What it the problem?

Edit: I always encrypt the system partition, but the board has no TPM and the CPU does not support AES. May this be a problem?

Thanks in advance.


One quick way to find out, is to install without encryption and see if it still fails. If it doesn’t, then yes, it’s because of encryption. If it does fail, it’s something else.

No still no work.

Also quite interesting when I try to install grub via console.

edit: su was missing, but still no work:

something with “overlay” not found.

Make sure your target disk is umounted before installing.

Tried that: failed to get canonical path of “dev” if I set the path to /dev/sda1

I tried also the previous build with Kernel 5.10 but it ends up with the same failure.

I installed xubuntu and had no problems with it, so it’s a Manjaro bug. I’ll keep it on that machine so the topic is closed.

It’s likely a Calamares bug. Manjaro uses Calamares as it’s installer. Ubuntu/Xubuntu does not.

Hm I haven’t had any probs with a Lenovo Ideapad 3 or my self-build now “old” Intel 10th gen. PC, so bad luck with that much older platform.