Installation fails while creating new partition

I have a old version of manjaro 8 I deleted the partition and am trying to reinstall.
This has a dual boot of windows 10. I has to fix windwos boot because it was damage.

now I can directly boot into windows 10. However, I now have an empty partition that I want to still
install the latest new manjaro linux. I use a usb boot drive and boot off the installation disk. I format the just the partition to ext4. I then run installation but it fails after deleting the partition and when it starts to create a new one in it’s place it fails. What can I do to fix this?

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information. [HowTo] Provide System Information
  2. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.

In addition to above advise - I would add the following:

While you are providing no useful details - such as which eidtion - venture an educated guess.

As many many users fancies KDE Plasma I am assuming you do as well.

KDE Plasma has a setting which - on some ISO - conflicts with Calamares.

If you issue is indeed occurring using the Manjaro KDE edition you can remedy the situation.

Navigate to System SettingsHardwareRemovable StorageRemovable Devices

Uncheck the options as illustrated below and restart the installer.

My system details:

CPU: AMD FX- 8350 8 core cpu x86-64
code name vishera

ram: ddr3 dual channel 665.7 mhz
32 gbytes G.Skill ram

motherboard Asus Sabertooth 990 FX R2.0
graphics ati radeon hd 7800 series . 2 gigs

hard driive is a sata western digital 3TB drive.

I am using the manjaro v 21 gnome.
I used gparted to format the partition to ext4.
I ran the installer and it deletes that format and then when it tries to create a partition during installation it fails. I am using the replace partition method but have a blank formatted partition ext 4.

I can use gparted to create a partition but the installer fails to do this. what else info is neededed?

My system is a dual boot. I had manjaro v8 but I ran the installation the first time around and it had errors. I had to then fix the booting of windows 10.
So, now my system only boots directly into windows 10.

I want to create a dual boot.

is secure boot and fastboot disabled?
do you have bios or uefi
use ventoy to boot, and you can select with ventoy to boot with bios or uefi mode
try to unmount the partiton before install
try creating a new partiton table, either MBR or GPT

If I make a new partition table would it wipe the drive clean? I don’t want to have to reinstall windows 10.

secure boot and fast boot is disable in bios.
My bios is UEFI but has backwards capability…
the installs uses MBR. I do use ventoy to boot and uses the BIOS.
If I use the UEFI version it just wouldn’t boot anything at all.

I can boot with bios into manjaro v 21 live cd. I will check out and make sure it’s not mounted.
To my knowledge I don’t think it’s mounted at all. Otherwise gpart would have issues creating a new partition.

Yes. A new partition table will basically destroy the partition and file-system information on the drive. While technically it doesn’t “securely wipe” all of the data on the drive, you might as well consider it all gone, due to the type of data recovery needed to retrieve your files.

so check this list also:

Firmware checklist for BIOS systems

  • :white_small_square: Use latest available firmware
  • :white_small_square: Disable EFI
  • :white_small_square: Disable RAID option
  • :white_small_square: Enable AHCI

Firmware checklist for EFI Systems

  • :white_small_square: Disable CSM (Legacy) boot
  • :white_small_square: Disable Secure Boot
  • :white_small_square: Enable AHCI
  • :white_small_square: Use latest available firmware
  • :white_small_square: Disable Optane Memory and Rapid Storage Technology (RST)
  • :white_small_square: Disable RAID option
  • :white_small_square: Disable Fast Boot (if unable to boot from USB)

so if you are using uefi, its strange that you cant boot with uefi iso…
in live usb, run this command and check if its mounted:
lsblk -f - and the MOUNTPOINTS column should be empty
also run this command:
[ -d /sys/firmware/efi ] && echo UEFI || echo BIOS
and whats the output from it

and you can change the partition table directly from windows with the windows built in mbr2gpt tool, so need to reinstall anything… - but dont do that, we dont know what exactly is your issue yet