Installation fails: Partitions, bootloader

I managed to install Manjaro with default settings, but would like some non-default settings instead and am struggling with those:
• I would like to increase the amount of Swap compared to the default, but no matter what I do, the “Next” button on the manual partitioning page is greyed out. I reused partitions from the automatic install, does that not work? These were the settings:
· 1MiB free space
· Name /dev/nvme0n1p1, format FAT32, size 300MiB, flag boot
· Name /dev/nvme0n1p2, format ext4, size 3684070MiB
· Name /dev/nvme0n1p3, format linuxswap, size 131072MiB, FS label “swap”, no flag
· 2.48MiB free space
Are these manual partition settings correct for 64GB of Swap plus Hibernate? I shrank the main partition by 6066MiB compared to the default and increased the swap partition by the same amount.
• If I use the automatic partitioning instead and want to encrypt my system, it fails to create the partitions:
• In my first attempt with automatic partitioning and no encryption, it got a bit further, but then failed to install the bootloader: This did not happen when I started the installed with “sudo calamares -d”.
Are these bugs in the Manjaro installer or am I doing something wrong? The error messages at least are not the most informative ever and just greying out a button with no mouseover text tells me nothing. Most posts I found were about dual boot or other more complicated setups, here I just want to set up a new laptop with one system.

Flags are set up as follows on my (other) system:

  • EFI partition (the first one in your case) set to boot, esp
  • swap partition with swap flag set.

Hope this helps. NB: I’m assuming you’re installing in EFI mode rather than Legacy. If it’s legacy, you will need a small, unformatted partition at the start with the bios_grub flag set.

As for why the automatic installation is getting stuck, afraid I’m at a loss there as I always do it manually inc. partitioning.

1 Like

I have no option “esp” there. From memory: There are only two flag options there, one “boot”, the other I think is named “boot-something”. But both changes would probably not affect the “Next” button, right? What could even cause it to be greyed out?

I seem to recall having to type the flags in on one system. Sorry I don’t know what is up with the installer. Guess the .ISO verified OK?

Also, I edited my previous post to add a bit.

The minimum is a Root partition (/) and an EFI partition with “boot” flag set and I am pretty sure, with a folder set and the normal folder is /boot/efi from what I’ve seen. Swap is optional, you can solve that later, with swap partition, swapfile or in RAM with for example Zram. Fedora uses Zram automatically out of the box.

@BG405 I cannot type flags in that UI.
@zhongsiu If I can get Swap set up now, I would prefer that instead of hacking it in later, so I will try that first.

I have now made a new partition table to make all the partitions from scratch and guessed some stuff that seemed right:
• 300MiB, fat32, mount to /boot/efi, flag “boot”
• 3684073MiB, ext4, mount to /, encrypt, flag “root”
• 131072MiB, linuxswap, encrypt, flag “swap”, self-typed label “swap”
All the names are “New partition” and I cannot change them. There is no more empty space shown, although I guess there should be 0.48MiB.
Great news: I can click “Next”! The first time I did this after setting the first mount point to /boot, after which I got warned that it should be /boot/efi (so I redid everything to be safe) and also that it is not encryped… which is not possible, there is no such option there… so thanks, I guess…
Installation succeeded now! Next, I will test whether Swap and everything else works.

1 Like

I use Gparted usually before the install. Sometimes I use the graphical stuff distros ship with. But usually I install Gparted while booted into Live USB media. I am familiar with Gparted. I have used cfdisk, fdisk etc but prefer GUI.

Either way, I did a quick test on Arch in a VM with archinstall script. Because it is fast, small install. Arch by default wants to set EFI up in /boot. I tried switching it to /boot/efi. Grub fails at “no such folder or directory: /boot/efi/grub/grub.cfg” or very similar error and the install fails. Now, /boot is fine, it finishes the install. So I am confused. The arch script was I think, so not current. So I wonder. Is Grub hardcoded /EFI-folder/grub/grub.cfg, on Arch? In the script? Normally Grub is in /boot/grub/grub.cfg.

Every other distro I have always set it up in /boot/efi.

Glad it works for you, it can be confusing.

Btw, Arch install wants me to type in sector numbers if I partition manually. I don’t remember anything about those, that was used last in the 80s/90s. First sector should start at 2048. That I remembered after I let Arch do it for me and I then went in manually. Wouldn’t something newer like cfdisk or similar be more fitting? Something where you can type in Megs, Gigs, Terabytes? sgdisk/cgdisk.

Which version of the Manjaro Iso do you use ?

Good point. Which edition? Don’t think I saw that in this thread.

Important: Using an out-of-date one will very likely cause issues when it comes to the first update you try.

Also, as I previously mentioned, make sure to verify it!

In my case the calamares installer did not even saw my nvme drive (more than 2 year old bug judging by other forums). So i did the partitioning first with gparted. And then it saw it. And in gparted there is an esp flag.

Calamares is basically saying the esp is not mounted, so you can check this too with gparted. And mount it manually if needed and then it should work, i hope.

Good point (it’s also in KDE Partition Manager, which is what I use). I just assumed Calamares also had that option. :blush: It does seem rather limited.

The partitioning is false.

Annoying: Before booting, the keyboard layout is apparently the USA default, which means that I cannot just type the special characters in my password. I was able to unlock it by trying all the buttons in the GRUB rescue console, noting down what labels the correct buttons have on my keyboard and then blindly typing that instead on the next attempt, but that would mean memorising the “wrong” password as well. So instead, I reinstalled the system again with yet another “wrong” password, where the special characters are translated the other way, so that I can type as if I used a German keyboard and the system will receive the other one. Bit complicated, but I can understand why one would not want to include the whole wide world of keyboard layouts in the pre-boot logic. (I also switched the order of swap and root partition and gave all partitions labels this time.)
The stage “Attempting to decrypt master key…” takes 46 seconds, which probably doubles the startup time. Meh, not great, but I will likely only start my laptop once on most days, so it is fine. Unlike my old laptop, this one does NOT sound like a broken tractor while doing nothing, so I can leave it running without going insane. :smiley:
Interesting: WLAN is already configured like in the live system, I did not have to enter that password again. Nice attention to detail, Manjaro maintainers!
On the previous system, Dolphin file manager showed “3,5 TiB Internal Drive (dm-0)” and “3,5 TiB Encrypted Drive”, which both lead to / and also “128,0 GiB Encrypted Drive”, which failed to mount. Weird, but I can just hide two of them. On the new install, “3,5 TiB Internal Drive (dm-0)” was renamed to “root”, like my file system label, but otherwise it is the same.
Sleep works, but is hard to get out of (tried pressing keys, pressing the power button, holding the power button, almost killed the system by holding it too long, but eventually it woke up), hibernate just turns the screen off for a moment and then goes to the lock screen. I could put even more effort into getting that to work, but I think I will just live with no hibernation. So many programs have problems with it that it is quite risky to use anyway.
I ran some benchmarks, the laptop generally gets rated quite highly, but not top-tier, as expected. A test that was supposed to use “~138GB” crashed and closed the console despite 64GB of RAM and 128GB of Swap, but I think that is an issue in the estimate, it looked fine in KSysGuard, so Swap definitely works. Also otherwise I see no issues.
@Keruskerfuerst manjaro-kde-23.1.4-240406-linux66.iso
@BG405 Updates worked fine, but there were just a few, Firefox and such. I did check the checksum. Any other verification I should do?
@Teo When I open KDE partition manager in the installed system, the only flag I see is the “boot” one. Weird.
@Keruskerfuerst What about it is false? It seems to work just fine.

If you wish to use hibernation, in your case, 65GB is recommended (this allows a little overhead, should it be needed). Many here will no doubt have a reflex comment to the effect “you only need half that”; and that’s arguably true only if you do not intend to use hibernation.

This table is a good indicator; and might be the choices given in a 16GB RAM system; these are the options given when using the Erase Disk partitioning method. For best control of your system, I recomend only using the Manual Partitioning method.

Preference Size Description
No Swap 0 If no Swap is defined, and later you need it, a Swap partition or file must be manually configured. It is recommended to configure Swap now; during installation.
Swap (No Hibernate) 8.80 GiB Default swap partition size is approximately half the amount of your system RAM if ‘No Hibernate’ is selected.
Swap (With Hibernate) 17.18 GiB Default swap partition size is approximately equal to the amount of your system RAM if ‘With Hibernate’ is selected.
Swap to file dynamic Swap file will be created under / (root) by default.

The $esp is automatically created when using the Erase Disk partitioning method. There is no wonder that you didn’t see it, in that case.

Since I have plenty of space, I kept the 128GB of Swap, that should be enough for any large operations (except for that one benchmark, I guess).