Installation failed grub error

I’ve had Win 10 installed, but i decided to move to Manjaro as my main OS i used Ventoy to make usb, and i booted to manjaro but when it comes to the step where it’s supposed to be installing bootloader i get this error.

( i would post screenshot but the forum doesn’t allow me to, and links aren’t allowed too)

i have tried wiping whole disk using gparted and installing manjrao couple of times and it doesn’t work, I even tried manually creating efi partition which is 512 mb
in size and vfat (FAT32) Filesystem, i did marked it as boot flag and mountpoint as /boot/efi but i still keep getting the same error, i tried installing some other linux distros and they also have the same error, openSUSE tumblweed has similar error when it comes to installing, but after installing it does boot so thats what im using now until i find a solution to this problem.

the device im using is Asus Vivobook max x541nc


he is my freind, im not sure why he cant post images but here is photo of his issue

1 Like

you can
recheck all options in EFI bios

  • no Secureboot

  • no fastboot

  • no legacy

  • no CSM

  • all disks on AHCI

  • no optane(rst)

  • may be keep USB storage on

boot on USB iso manjaro
open a terminal

inxi  -Fxza ( check for UEFI or bios , not UEFI[legacy] )
test -d /sys/firmware/efi && echo efi || echo bios
sudo efibootmgr -v
sudo parted -l ( GPT is better case )

then redo installation ,
EFI + GPT + /boot/efi or
GPT(bios_grub flag & part 33Mo NOT FORMATTED )

my bios only has the option for AHCI, fastboot & Secureboot.
I don’t have any other options that you have listed.

Thank you i have successfully installed manjaro!
( i did a little bit of a research on the internet)

Here’s what i did

  1. I cleared boot records from NVRAM sudo efibootmgr -b 4 -B replace the number “4” with the boot record number

  2. I reset my bios to defaults, and then i disabled Secureboot, legacy, and i made sure that AHCI is enabled.

  3. I used gparted to wipe my whole drive to “untitled” free space.

  4. In the manjaro installer i have selected option “Manual Partitioning” and there i have set my new partition table to be GUID partition table (gpt), and i have created a fat32 partition with the size of 500 MiB with mount-point “/boot/efi” with bios-grub, boot as flags, and i have created the second partition, an ext4 partition that will be my root partition, i have set the needed amount of space about 102000 MiB and i have set the mount-points to root “/” with flag “root”, and i have created third ext4 partition 4328 MiB with flag “swap” and no mount-point, and that partition will be used as swap.

  5. I pressed install and everything went through, I now have manjaro installed and it boots.

(hopefully this will help someone else with the same/similar problem)

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.