Installation cancelled because of error

Hi guys!
I have just written Manjaro image to USB stick and tried to install. I have quite old motherboard of early 2010s, it has UEFI, and I installed Manjaro image to USB flash with GPT.
During installation I chose ‘replace partition’ and selected empty 28GB space. But I noticed it also added 4GB partition, so in sum I get 32GB for Manjaro on my HDD. I haven’t noticed that my NTFS partition near these 28GB space shortened.
Then clicked install and went to other room. I noticed that the system copies files normally. But after I returned from the other room I found that installation got error:

Установка завершилась неудачей
Boost.Python ошибка в задаче "bootloader".
Command 'grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Manjaro --force' returned non-zero exit status 1.
Installing for x86_64-efi platform. Could not prepare Boot variable: No space left on device grub-install: error: efibootmgr failed to register the boot entry: Input/output error.

File "/usr/lib/calamares/modules/bootloader/", line 476, in run

  File "/usr/lib/calamares/modules/bootloader/", line 448, in prepare_bootloader
    install_grub(efi_directory, fw_type)

  File "/usr/lib/calamares/modules/bootloader/", line 310, in install_grub

  File "<string>", line 6, in <module>

As I think the system doesn’t have enough space on boot partition.
I tried to try to install Manjaro again, but it has only Manual partitioning option, but I don’t know how to partition manually and also save my Windows 10 OS on the HDD.
Could please point me some directions what I should do to finally install Manjaro successfully?
For now I get next picture of partitions:
/dev/sda1 FAT32 100 MiB
/dev/sda2 Unknown 16 MiB
/dev/sda3 NTFS 432,8 GiB
/dev/sda6 ext4 28,3 GiB
/dev/sda4 Unknown 4,0 GiB
/dev/sda5 NTFS 509,0 MiB
Free space Unknown 1,0 MiB

Hello @KS-10 :wink:

  1. You could increase sda1 with gparted or kparted. Then you would have enough space.
  2. Another way would be creating a second EFI partition for Manjaro and mount it on /boot/efi and mount sda6 as / (root). But some UEFIs could have problems with that.

If you mean that one:

then i would bet that it was already there. The installer just shrink sda3 and created sda6.

Hi and welcome to the forum :+1:
Please see:

It is not clear where you installed your Manjaro, because you say different things:

So please post info as instructed in that page i linked above so people wanting to help you have more relevant info on your hardware.

Extra info which might be needed are the outputs of these commands:

  • efibootmgr -v
  • sudo lsblk -l
  • and perhaps sudo fdisk -l to check for partition type codes.

Sorry but that is bad advice because the UEFI will only recognize and use the first ESP per hard disk…
Some might only recognize one ESP, others might collect info of all ESP’s on different HD’s, but still using only the first per HD…

Sorry, but at least on my laptop i have 3 efi partitions on the same hdd and i can choose in the efi bootloader which OS i want to boot… however experience differs and there are different UEFIs. And i said:

So better try, if the UEFI can handle this before saying: NO NEVER :clown_face:

Being able to configure an UEFI boot entry to use a bootloader on any partition (even extra ESP partitions) is something different as the UEFI bios automatically recognizing entries in the vendor directories of those extra ESP on the same HD.

But anyhow lets not derail from the OP…