Install UEFI motherboard ASUS , RADEON, disk NVME last microcode Flash ASUS

Good morning,

the installation works perfectly under UEFI (XFCE) but this is valid for others

After using an HP Z800/600 for 18 years, having known Manjaro from the beginning, I have just acquired a new station to configure room by room:

2023-10 latest flash microcode
The base, an ASUS card (B560-PLUS) and more, particularities for the Linux configuration to take into account:
I don’t have bluetooth (a choice), nor boot from the network.

This will save you a lot of hassle (read until the end before doing anything)
make backups of your files before starting

Local Storage: total: 942.71 GiB used: 71.82 GiB (7.6%)
ID-1: /dev/nvme0n1 vendor: Corsair model: MP600 GS size: 465.76 GiB → SSD FLASH
ID-2: /dev/sda vendor: Kingston model: SKC600256G size: 238.47 GiB
ID-3: /dev/sdb vendor: Kingston model: SKC600256G size: 238.47 GiB

Device-1: AMD Navi 23 [Radeon RX 6600/6600 XT/6600M] driver: amdgpu
v: kernel

a) adjust your device, access to BIOS-SYSTEM


advanced mode:

Advanced tab: UEFI variable protection (enable)

Startup tab
CSM execution (enabled)
boot device management (ROM UEFI and inherited)
network device management (ignore this custom)
storage device management (UEFI only)
PCI-E/PCI on-device management (UEFI only)

secure boot tab
Operating system type (Other OS)
Secure Boot Mode (Standard)

adjust your settings:

it is absolutely necessary to do this to avoid having a problem with the RADEON graphics card

sudo sed -i -r 's/.*MODULES=".*/MODULES="amdgpu"/g' /etc/mkinitcpio.conf

It is not mandatory
for the needs of a console in French or Latin at startup

sudo mkinitcpio -P

sudo pacman -S arandr

sudo hwinfo –framebuffer

for this to be readable, I have a screen larger than 32" ( 3600x2500

sudo sed -i -r 's/.*GRUB_GFXMODE*.*/GRUB_GFXMODE=1920x1080x32/g'/etc/default/grub

sudo update-grub

for NVME flash drives:
if you have a message

journalctl -p err -b

oct. 01 10:47:37 dragon kernel: hub 8-0:1.0: config failed, hub doesn’t have any ports! (err -19)

jounalctl -F show that it is correct

Local Storage: total: 942.71 GiB used: 72.3 GiB (7.7%)
ID-1: /dev/nvme0n1 vendor: Corsair model: MP600 GS size: 465.76 GiB

grub-mkconfig …
/usr/bin/grub-probe: warning: unknown device type nvme0n1.

This is the probe that should be corrected in the future!!!
C’est le probe qui devrait être corrigé dans un avenir !!!!
It’s a spurious warning ─ you can ignore it. :sweat_smile: :hot_face:

which allowed me to have less white hair :joy: :heart_eyes:

for those like me who don’t have bluetooth:

this will save you from messages in the journalctl

sudo systemctl stop bluetooth.service
sudo systemctl disable bluetooth.service
sudo sed -Ei '/load-module module-bluetooth*/s/^/#/' /etc/pulse/
sudo sed -i -r 's/.*.include \/etc\/pulse\/*/#.include \/etc\/pulse\/' /etc/pulse/

sudo pacman -Rcns blueman

The famous error in XFCE never corrected

#gkr-pam: unable to locate daemon control file → journalctl
sudo pacman -Rns gnome-keyring

I thank MANJARO and ARCH for their answers.

installation partition

  1. 512 fat 32 flag bisogrub boot/efi boot

  2. ext4 flag /

  3. ext4 flag /HOME

  4. swap

What did I just read? I think I got aneurysm.

1 Like

oh me then, I spent time trying to make it work for a workstation but it lasts me as long as the last one (18 years) so I’m a winner

if CSM is activated → you have a bios flag on /boot/efi ,
not activated it should be boot & esp flag.

on USB boot iso manjaro have you chosen :

  • < manjaro > ( ==> bios install )
  • < manjaro >(< partition 1 > ( ==> UEFI install )

yes cms actived ; As show in the picture above
Otherwise, I do not have access to the other system window