Install Steam games on a partitioned drive, how to?

Hello folks.

I hope I can get help here or get pointed to were I should turn with my problem even though it is strictly related to Manjaro but I figure that I cannot be the only one whom had this problem and I got to star somewhere. I am also still a newbie at Linux, been on Kubuntu for a little more then a year and just switched to Manjaro so I ask kindly for your patience with me.

I have a 4 TB drive that I partitioned as I want to have my OS, Manjaro, in one partition and Games in another partition. Now I tried to make Steam install games on the “Game” partition but it failed for me. I navigated in steam as the following “Steam>Settings>Downloads>Steam Library Folders” then use the “+” sign to add a new path. Next navigating to the drive /dev/sda4/ (only place i can find the partition so I assume it is correct location) and add new folder, which gives me the error “Failed to create a folder, this drive is read-only.” This only makes me think that it is all an issue with permission. When I partitioned the drive I used “sudo chown MYNAME /run/media/MYNAME/Games -R” to set my self as the owner but this is not enough to get steam to install games were I want them to.
So how do I give steam permissions to install the games at the location I want?

I tried google to find help but as of yet I have at best found a video on Youtube (cannot include the link) were the video shows how to do it but they way he is doing it does not work for me as he starts the clip with “cd /media” this could be because he uses Ubuntu.
Anyone have any ideas on what I need to do in order to make steam games install on my “Game” partition?

Kind regards.

There you can’t create any folder. It is the device and not a folder of the mounted device.

# change owner:group
sudo chown -R $USER:$USER  /run/media/$USER/Games

also maybe useful:

# set full access permissions for everyone
sudo chmod -R 777  /run/media/$USER/Games

I hope the drive has a Linux Filesystem and not NTFS, FAT32 etc…

Beside I would recommend to mount it like that, if it is not an external drive:

  1. Check the UUID:
sudo blkid /dev/sda4
  1. Add a fstab entry:
UUID=<UUID> /media/games ext4 defaults,noatime 0 2

Open /etc/fstab as root with an editor and add this on a new line and put in the correct UUID and filesystem name (if ext4 is not correct) there.

  1. Create the folder and mount it:
sudo mkdir -p /media/games
sudo mount /media/games

Now it should be automatically mounted on boot.

Note: /media is normally not there, but that is the default location for such partition when using permanent mount. /run/media is used for temporary mounts per user.

1 Like

You cannot direct steam to a device directly - you need to mount it first.

Secondly you cannot create permanent mountpoints in the /run tree because it is recreated on every boot and every login.

You need doing something like this

Then create mount the device using using either fstab or a mount unit.

hello !
I have my steam games on second ssd
What i did

  • create a folder GAMES in /mnt (so timeshift will not save your games)
  • mount second ssd on /mnt/GAMES (fstab)
  • create a folder STEAM in /mnt/GAMES
  • start steam
  • tell steam to download in /mnt/GAMES/STEAM set location as default

@ megavolt, I did the following:

sudo chown -R $USER:$USER  /run/media/$USER/Games


tsudo chmod -R 777  /run/media/$USER/Games

with my username of course and got nothing posted as a response, then it was done correctly i beleave.

I hope the drive has a Linux Filesystem and not NTFS, FAT32 etc…

Yes, it is a Linux ext4 filesystem.

When trying to check the UUID using:

blkid /dev/sda4

I get no response at all but I do think I should have gotten a response as I need the ID to complete next step right? What did I do wrong?

As far as I understand it the drive is mounted but I am sure I am the one at fault here.

Secondly you cannot create permanent mountpoints in the /run tree because it is recreated on every boot and every login.

I really do not get what you are saying, I am sorry. The /run pops up as the path in terminal when I open up a terminal from the File manager.
The link you posted, you are suggesting to create a folder outside of /home to be shared amongst all users? In this case the folder would be on me partition sda4?

Oh sorry, it is:

sudo blkid /dev/sda4

Corrected it above.

Thank you, now I got a response.
I might be sharing something I shouldn’t do now but I got to.

/dev/sda4: LABEL="Games" UUID="60960fa5-bd11-4a1e-8c21-3c6480a9e059" BLOCK_SIZE="4096" TYPE="ext4" PARTLABEL="Games" PARTUUID="9fae6578-a448-4e74-907b-be88c8d1ef57"

This is the response I got, do I use the UUID or the PARTUUID?

Doesn’t really matter… you can use:

  1. LABEL=
  2. UUID=

But in anyway, DON’T USE double quotes "" in fstab.

I think it is easier to use LABEL=, but UUID= is the default.

It works, thanks a million! :smiley:

I do have to ask. I did not use double quotes as you said in fstab but why should I not use them?

Because the syntax is incompatible. Users see the output of blkid and say: “Hey, i will just copy&paste it” and then they run into troubles. I don’t know if it works now (or anything has been changed), but in the past it does not work.

Thank you for clearing that up.
I forgot one thing.
Now in File Manager I got a folder called “games” with a unmount symbol and the one I made “Games” that are the same drive (/dev/sda4), can I remove the one I did a few days ago or do I need to keep both?

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.