Install manjaro-kde-20.0.3 on hyper-v: Failed to start Simple Desktop Display Manager

I was trying to install manjaro-kde-20.0.3 on hyper-v. it failed at booting “manjaro-kde-20.0.3-200606-linux56.iso”

Hello & Welcome

please test a current image


1 Like

Same problem


Which iso exactly did you try to install this time?


please read it
same problem here?

use the links …

could there be a command to limit errors / more information?

Please do not post photos, we love logs :slight_smile:

Having the same problem when installing this version on Hyper-V. Tried Gen1 VM. Installing SDDM (which was not installed) parallel in Terminal works but starting it fails.

I too have the same issue - “[Failed] Failed to start Simple Desktop Display Manager”. Hyper-V VM, Nvidia GPU and Windows 10 are involved. The Manjaro with KDE distro is not installed yet. I’m booting the stable x64 ISO I just downloaded from Manjaro.

I’m an IT pro/Software dev but on the Microsoft platform. I’m a total newbie when it comes to Linux. Manjaro was recommended as the most beginner friendly linux distro. If I can’t fix this issue in the next hour, I will be moving on to Ubuntu or something else.

Apologies for necro, but I had the same issue on 20.1.2 which made booting from the iso on hyper-v difficult, and I could not find any answers when looking for sddm, but I found the solution on Jacob Sobczak’s blog (new member, can’t post link) by looking for the same problem on lightdm.

sudo pacman -Sy
sudo pacman -S xf86-video-fbdev
sudo systemctl start sddm

It would be nice if xf86-video-fbdev or similar was included as standard so that these isos just worked under hyper-v.

I tried installing xf86-video-fbdev as decribed but this had no effect at all, nothing happens when executing trying to start SDDM after installing this package.

It occurred to me you where using the 20.10 iso from which was current in December, after downloading this iso the above work around works.
However with the latest 20.2.1 iso it doesn’t work anymore, when executing SDDM at this end the commandline remains and nothing happens at all.

Any suggestions ?

Don’t use HyperV - It is proprietary product and is largely designed to run Microsoft operating systems.