Install Layout Switcher on Arch Linux

There is a way to install Layout Switcher on Arch Linux?

Yes. You can install it like any other AUR package with makepkg.

Disclaimer: There may be packages in the Manjaro repos not available in the Arch repos. You can also find them on our GitLab and some may also be available in the AUR.

I can´t install this it says
makepkg -si
== > Making package: gnome-layout-switcher 0.8.36-2 (Tue 02 Jan 2024 02:16:44 PM UTC)
== > Checking runtime dependencies …
== > Installing missing dependencies …
error: target not found: dynamic-wallpaper
error: target not found: gnome-shell-extension-gtk4-desktop-icons-ng
error: target not found: gradience
error: target not found: pamac-gtk
== > ERROR: ‘pacman’ failed to install missing dependencies.
== > Missing dependencies:
→ dynamic-wallpaper
→ gnome-shell-extension-appindicator
→ gnome-shell-extension-gtk4-desktop-icons-ng
→ gradience
→ pamac-gtk
== > Checking buildtime dependencies …
== > ERROR: Could not resolve all dependencies.

I think you missed the disclaimer part

You will have to resolve the dependencies manually just like you would any other custom script

How to fix?

Read the manual Arch User Repository - ArchWiki

Or use Manjaro

I tried today again and now said pkgbuild does not exist


Moderator edit: Replaced useless screenshot with link to referenced repo

This post was flagged by the community and is temporarily hidden.

That’s the upstream repo.

Hint: The link to the package repo is in this thread above. :wink:

I have to install only pamac-gtk but I don’t found pamac-gtk package on the web and on AUR!


Moderator edit: Removed useless screenshot. In the future, please copy and paste terminal output.

Now we’re going in circles. You already have the answers in this thread.