Install failed with "Bootloader installation error"

Trying to install from live media alongside windows 10.
Error as, “Bootloader installation error” error code 1.

Safeboot is turned off, confirmed both installation media and laptop storage are gpt.
Trying to install with manual partitioning with following options,
choose the existing FAT32 efi partition as mountpoint /boot/efi with flag boot.
format another partition as ext4 for /,
formation another partition as ext4 for /home

After looking into similar issues from the forum, tried sudo calamares -d, and got the same error with error as,

   ..  Job description from pretty_name "bootloader" = "Install bootloader." 
[PYTHON JOB]: "Bootloader: grub (efi)" 
    ..  Running ("grub-install", "--target=x86_64-efi", "--efi-directory=/boot/efi", "--bootloader-id=Manjaro", "--force") 
    ..  Target cmd: ("grub-install", "--target=x86_64-efi", "--efi-directory=/boot/efi", "--bootloader-id=Manjaro", "--force") Exit code: 1 output:
 Installing for x86_64-efi platform.
grub-install: error: cannot copy `/boot/grub/x86_64-efi/core.efi' to `/boot/efi/EFI/Manjaro/grubx64.efi': No space left on device.
WARNING: [PYTHON JOB]: "Command 'grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Manjaro --force' returned non-zero exit status 1." 
[PYTHON JOB]: "stdout:Installing for x86_64-efi platform.\ngrub-install: error: cannot copy `/boot/grub/x86_64-efi/core.efi' to `/boot/efi/EFI/Manjaro/grubx64.efi': No space left on device." 
[PYTHON JOB]: "stderr:None" 
05:11:50 [6]: virtual void Calamares::JobThread::run()
    Skipping non-emergency job "postcfg" 
    ..  Skipping non-emergency job "umount" 
05:11:50 [1]: void Calamares::ViewManager::onInstallationFailed(const QString&, const QString&)
    ERROR: Installation failed: "Bootloader installation error" 
    ..  - message: "Bootloader installation error" 
    ..  - details: The bootloader could not be installed. The installation command <pre>grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Manjaro --force</pre> returned error code 1.
05:11:50 [6]: void Calamares::ViewManager::onInstallationFailed(const QString&, const QString&)
    Calamares will quit when the dialog closes. 
05:11:50 [6]: void Config::doNotify(bool, bool)
    Notification not sent; completion: failed 
05:12:00 [6]: void Config::doRestart(bool)
    mode= "never"  user wants restart? false force restart? false 
Shutting down Calamares... 
    ..  Finished shutdown. 

Looked into other few similar issues and removed few entries from efibootmgr, and still got the same issue.
My EFI boot manager partition is fat32 with 625MB space. Checked via partition manager and it shows 96 MB used. So, got plenty of space left.
Any help appreciated.

Judging from the error grub-install: error: cannot copy /boot/grub/x86_64-efi/core.efi’ to /boot/efi/EFI/Manjaro/grubx64.efi': No space left on device., it seems there’s no more space for the EFI partition to place the GRUB bootloader.

Aside from checking the EFI partition size from the partition manager, try ls -l /boot/efi to see the actual filesystem size. The size displayed by ls is in bytes.

Also check the core.efi size by ls -l /boot/grub/x86_64-efi/core.efi.

This way you can tell if the /boot/efi is big enough to host the core.efi file.

Also, as far as I know, you need to set the flag for FAT32 efi partition flag boot and esp, not just boot alone. esp stands for “EFI System Partition”.

Not sure if the missing esp flag causes the /boot/efi filesystem size to be smaller than it should be.

Then show us fdisk -l on console.

Seems to be a partitioning issue.
Since it’s a new laptop, wiped out everything and started from scratch. Worked fine.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.