Install drivers for 0bda:f192 Realtek Semiconductor Corp. 802.11n WLAN Adapter

Hello everyone

what drivers i need to install

0bda:f192 Realtek Semiconductor Corp. 802.11n  WLAN Adapter

i install rtl8821cu-morrownr-dkms-git but not working for me

i have manjaro on macbook air 2010 :slight_smile:

Hi @nano1,

It took quite some Google-fu, but I came across this page where the accepted answer was installing the rtl8192fu kernel module. Upon a search, it seems it, or something like it is in the AUR:

$ pamac search rtl8192fu
rtl8192fu-dkms-git                                                                                                                                                                                                                AUR
Driver for Realtek RTL8192FU chipset wireless cards

So it can be easily installed as follows:

pamac build rtl8192fu-dkms-git

So, go ahead and try that. Reboot to see if it worked.

Hope it helps!


Almost forgot to mention:

If you’ve restarted and it works, remember to remove the wrong one:

pamac remove rtl8821cu-morrownr-dkms-git

thank you sooo much it work with me now :heart_eyes:

1 Like

Does this actually turn the dongle “on?”

AUR (en) - rtl8192fu-dkms-git

Last Updated: 2022-01-07 15:07 (UTC)

xx777 commented on 2023-06-15 05:54 (UTC):

rtl8xxxu supports RTL8192FU now. Use rtl8xxxu-dkms-git instead.

AUR (en) - rtl8xxxu-dkms-git

Last Updated: 2023-09-18 14:19 (UTC)

  1. If your usb wifi adapter is based on a RTL8188GU or RTL8192FU chip, you may need to use the command usb_modeswitch or eject to switch it to “Wifi Mode” first.
  2. Before installing this package, make sure that your system has the corresponding kernel headers installed.

Or, DuckDuck-fu, for extra privacy. :duck:

Solved my issue…2023-10-23T07:00:00Z

I have the driver installed :88x2b… but the intel 8260 chip in the thinkpad won’t let go. Most commands to shut off the wifi, shut it off completely, including the usb wifi. Clues?

What modules are at play?
unload the module you dont want and/or blacklist in it in /etc/modprobe.d

If you tell me exactly what modules … then I can tell you exactly what to do.
(find in inxi -Nazy, lsmod, etc)

I blacklisted the iwlwifi on Monday morning, as you suggest…The usb wifi is now working as it should. Thanks for your reply.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.