Install development ISO with Unstable

Good morning,
I’m sorry if the answer seems obvious to you but I try to install this version of Manjaro (unstable-kde) but every time I start I only get a black screen.
Is it even possible to install it please?
When I look at old threads this black screen issue is from 2021, am I doing something wrong?
Do you have a procedure to follow to install it (zip, z01…)?

Hoping that it is possible to install it natively, for my needs, thank you for this magnificent work!
Wishing you good luck.
Kind regards, Skwal

What exactly are you trying to achieve? kde-unstable branch is for developers. If you want Plasma 6, just install regular iso and switch to unstable branch.

Good morning,

I’m sorry, I’m not an English speaker and I’m using a translator, if my words don’t make sense I apologize.
I want to install unstable natively, and not go through branch switching, just to have a completely new and clean installation.
Before, it seems to me that you could via manjaro-architect, which is apparently no longer maintained.
Indeed, I want plasma-6 but also synchronization with Archlinux packages.

Kind regards, Skwal

Good morning and welcome to Manjaro,

Do I understand correctly that you were able to;

  • Download the split zip archives
  • Combine them into an ISO
  • Verify the contents of that ISO
  • Write the ISO to some media (USB?)

But when you try to boot the media you encounter a black screen?

If so please also report at what stage this occurs.

Are you able to see GRUB bootloader at first?

If you could also include some basic system information that may help us as well.

Hello and thank you, also for opening a new topic,

Here is the procedure I followed, I was able to combine the two files (zip, z01):

7z x manjaro-kde-dev-24.04-development-unstable-240410-linux67.iso.z01

By having both files in the same directory.
Then I checked the checksum:

sha256sum manjaro-kde-dev-24.04-development-unstable-240410-linux67.iso: 443d51928b14c48fdbc4bebe36bba6a7763db95ebcfc550c828442b6f536c477 manjaro-kde-dev-24.04-development-unstable-240 410-linux67.iso

cat manjaro-kde-dev-24.04-development-unstable-240410-linux67.iso.sha256:

443d51928b14c48fdbc4bebe36bba6a7763db95ebcfc550c828442b6f536c477 manjaro-kde-dev-24.04-development-unstable-240410-linux67.iso

It’s the same channels, so ok. I continue.

I then put the iso in ventoy, very practical, I can go to the start menu choose the languages and launch Manjaro which seems to load (with grub2) but that’s where the screen remains black and the keyboard (which lights up) does not respond (no ctrl + alt + f*).

The result is the same if I put the ISO on a USB key via dd.

Configuration: View paste BWEA

Hoping to have provided you with all the information requested, thank you.

We have python script which are capable of fetching the development ISO, assemble the parts and verify the signature

When the ISO has been verified - it is recommended to use Ventoy to prepare an USB stick - then do a simple one-to-one copy e.g. drag the ISO onto the USB.

Using the script - if you prepare the stick in advance and mount it - be sure it has room for bot the archive and the extracted ISO

 get-iso -p plasma -o <usb-mount-point>

Good morning,

I went through manjaro-iso-downloader yesterday, but the result is the same.
I tested three or four times with “plasma” and “plasma-daily”.
Maybe a problem with my bios configuration, but I test a LOT of Linux distributions and have never had a problem with the ISOs.
Far be it from me to criticize you, I am mainly raising the problem and would have liked to get there, I think you are doing a very good job and thank you for it.

Edit: A member of the fr community got there with build-iso.
Once again, thank you.
Best wishes .

It looks like the development iso is using a kernel no longer in the repo.

I am doing a local test run on the kde-dev profile - I can supply you a link to the ISO when I have tested it

It is a minimal ISO - unstable branch - Linux 6.8 - let me know if it is an option.

1 Like

I would be happy to test your iso.
If when you talk about options you talk about the minimum option I usually go with full, but I can assemble the system from minimal I think.

I remain at your disposal to test, if you wish.

Thanks again :slightly_smiling_face:

I’ve been talking with the community now, the problem seems to be of interest.
When you test locally do you test in VM? Fred6681
tells me that if you test in VM it may not work but work very well in hard yes.

Thanks again !

I pm’ed you the location of my archive

I usually test in VM - but this one acts strange in my vm - both virtualbox and vmware.

I have tested this one on bare metal - for the reason above.

1 Like

Fred6681 says it’s normal, it was better to warn you. Unfortunately I can’t tell you why, I don’t have the adequate knowledge.
I will come back to you as soon as I have downloaded and installed Manjaro, it will be done within two or three hours maximum. :wink:

So, the installation was launched and completed without errors. :grinning:

Unfortunately at startup, by not touching anything, I get this message:

error: start_image() returned 0x80000000000000001.
Failed to start default entry and fallback entries.

To be able to boot on the installed system I had to go through grub and use fallback, there the system launched normally.

I tried “mkinitcpio -P && update-grub” to try to fix this, but without success.
What do you recommend for me please?
If you want me to try other ISOs don’t hesitate, it’s on my main computer and in the meantime I don’t know what to do.


Edit: It seems that Ventoy could pose a problem, I will try again with dd.

when using ventoy - select grub mode after selecting the iso

I tried several solutions before coming to you, both types of start-up are among them.
I tried both types of installation equally. :wink:
During my research I came across a similar problem:

I’m rewriting the key with dd, I’ll see if that changes anything.
Obviously I’ll come back to see you afterwards to tell you what’s going on. :grinning:

Well - I did boot it on a clevo laptop and I did install it too - so I know the ISO works.

Using ventoy
→ boot
→ select the ISO
→ select grub mode

if that doesn’t do on your hardware :man_shrugging:

If you system firmware is 32-bit EfI there is some limitations - Manjaro does not support 32-bit EFI.

Such system should boot in BIOS mode - MBR limits the number of primary partitions to 4 which is an advanced scenario if you are going to dual boot windows and I cannot help you troubleshoot such setup - don’t get we wrong - the correct phrase is -I will not - troubleshoot such setup - I don’t have the experience required.

Not all bios firmware supports booting in BIOS/GPT mode - and installing in BIOS/GPT mode requires you to manually create an 8MB unformatted partition - tick the bios-boot option.

1 Like

Thanks Linux-Aarhus,

It seems that my problem comes from my bios, when your iso was launching earlier it is no longer launching now.
I am currently in the bios to try to resolve this, but as it is very recent it may be too recent.

I suspect that my problem therefore comes from the configuration or newness of my bios.
I’m sorry if I wasted your time.
When I find the source of the problem I will report it here in case it helps anyone.

All profiles have been updated to use linux68, by the way.

1 Like