Install Brother HL 2135W via AUR

Getting my old Brother HL-2135W run print on Manjaro 23.0 (and the version before) had given me a little headache, but the solution was actually very simple. The easy workaround was simply installing and using another (more general) ppd from the AUR, than the one I would have expected. Hence, the solution that worked for me.


  1. The drivers for that particular printer are not available inside the CUPS database
  2. The printer was recognized, but drivers chosen by the CUPS wizard did not work for me
  3. The AUR includes a .ppd called hl-2135w, which also did not work for me


  1. (Allow AUR in third-party setting of pacman GUI)
  2. Search/Choose the AUR called “brother-hl2130” (instead of hl2135w)
  3. After installing the AUR. Just point (Printer details - install PPD) to the ppd available in: urs/share/cups/model/HL2130.ppd

Please note, that I’ve installed the printer via a direct connection through a USB cable. I didn’t bother to check on the wireless network functionality yet. Though, this is a very simple (maybe even obvious) workaround, I hope it might be useful to somebody also using that old brother model.

This .ppd worked flawlessly for me

This .ppd did not quite work for me

Hello @marrod :wink:

Instead of posting it here, it would be a better idea to report it to the maintainer of this AUR Package:

Maintainer: Alexander Stephan <xan at discolovers dot de>
PKGBUILD - aur.git - AUR Package Repositories

Either leave a comment and send him a mail.


That’s indeed a very good hint. Will do. Thanks.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.