Install a driver for Nineplus USB WiFi Adapter 802.11AC 1200 (rtl88x2bu)

It just occurred to me why it might be hidden from lsusb. Maybe it gets disconnected very quickly from the kernel, because there is no firmware is the system for it. You can check with sudo dmesg
Unplug. Run command, copy the last lines somewhere. Plug. Run command again. And compare if there are a couple of new lines there regarding the device, if yes, than the device is physically (electrically) ok and the problem is the firmware and driver.

Hi @loimp ,

Maybe, your problem is related to this post:
Connected ethernet but no internet

Hope it help,


I cannot see any similarity…at all. He does not have a driver, it is not a connection is dropping because dhcp or ipv6 fails, or rfkill or tlp decides to save power and disconnects after X minutes. These problems will (hopefully never) come later. But first a driver is needed.

[ 4272.561371] [UFW BLOCK] IN=wlp10s0f3u1 OUT= MAC=01:00:5e:00:00:01:70:df:f7:5d:96:70:08:00 SRC= DST= LEN=36 TOS=0x00 PREC=0xC0 TTL=1 ID=13594 DF PROTO=2 
[ 4397.564350] [UFW BLOCK] IN=wlp10s0f3u1 OUT= MAC=01:00:5e:00:00:01:70:df:f7:5d:96:70:08:00 SRC= DST= LEN=36 TOS=0x00 PREC=0xC0 TTL=1 ID=2871 DF PROTO=2 
[ 4602.526089] usb 1-1: new high-speed USB device number 7 using xhci_hcd
[ 4602.695779] usb 1-1: New USB device found, idVendor=0bda, idProduct=b812, bcdDevice= 2.10
[ 4602.695787] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 4602.695790] usb 1-1: Product: 802.11ac NIC
[ 4602.695792] usb 1-1: Manufacturer: Realtek
[ 4602.695793] usb 1-1: SerialNumber: 123456
[ 4772.572677] [UFW BLOCK] IN=wlp10s0f3u1 OUT= MAC=01:00:5e:00:00:01:70:df:f7:5d:96:70:08:00 SRC= DST= LEN=36 TOS=0x00 PREC=0xC0 TTL=1 ID=55128 DF PROTO=2 
[ 4897.575638] [UFW BLOCK] IN=wlp10s0f3u1 OUT= MAC=01:00:5e:00:00:01:70:df:f7:5d:96:70:08:00 SRC= DST= LEN=36 TOS=0x00 PREC=0xC0 TTL=1 ID=23083 DF PROTO=2 
[mikaloi@mikaloi ~]$ 

with and without firewall enabled

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

The device is supported by kernel versions 6.2 and newer according to the LKDDb

1 Like

I did what you said with dmesg and as soon as I saw “ufw” I disabled it and ran dmesg again . so I just unplugged the old adapter and the new one is not working - needs a driver .

Have you tried with kernel 6.4 ?
The post before yours indicates you must use 6.2 or newer (with 6.2 and 6.3 being EOL).

sudo mhwd-kernel -i linux64

so , I need to move up to 6.3. . that’s what my settings mgr shows

oh, I was typing

oh , didn’t realise 6.3 is eol

ok you guys , I never did this before successfully’ I need help for this I think . 1st , shouldn’t I read release notes or something and check out any issues and I thought I saw some suggestions when I looked last week . too much for me . I got scared and steered away from that. BUT I’ll do it , just need help. gotta step away for 10 mins.

What do you mean? Updates? Installing a kernel?
Those are the only things you need to do … and updates only if you arent up to date.
Installing a kernel is a simple single command above (or few clicks in Manjaro Settings Manager).
Then you simply select that kernel from grub during boot.
(or, in the case that it is newer, will likely be booted into automatically)
Also note it does not mean uninstalling the previous kernel.

so, just bring up Manjaro Settings Manager/ Kernel and install 6.4.0_rt6-2 ?

I think I was reading about another distro .

Just go to Manjaro Settings - kernel and click install on 6.4. Not 6.4-rt. DO Not uninstall anything.
Reboot. If something happens and you cannot boot with the 6.4, you hit ESC to show the grub menu and with the arrows choose “Advanced options” - kernel 6.1 (not 6.1 fallback). You can try that with ESC beforehand just not to be scared.

Not the RT one … thats a realtime kernel for audio producers, etc.

oh, ok. here go’s.

after this I need to start another thread/topic.

says it’s still retrieving pkgs

well , I think there must be something wrong here . I must have done something

Depending of if you have firmware and headers a kernel can be a couple of hundred MB.
I edited the title so it is more relevant for the forum search in the future.

Crossing fingers.

I see it . much better . specific.

I think I need to just take 15 min. and reinstall and start all this from the beginning . I been thinking lately I might have some piece of hardware failing too. my next thread . diagnostics.

I timed it. it took 36 seconds for add or remove to open . that’s become typical of various apps .

ok, back in 10.

You’ve probably got xdg-desktop-portal-gnome installed, replace it with xdg-desktop-portal-gtk.

in add or remove ?

well , something drastically wrong . I pasted xdg-desktop-portal-gnome into search bar in add or remove and the whole window starts flickering and shaking. even after I closed the kernel installer

j8a , andreas85 ,
Teo , Yochanan ,
cscs ,

I thank all of you for your help today. 

where I’m at now. I’ve noticed lately my machine seems slow in certain things - opening local apps, firefox , add/remove, - thats for a diiff thread tho . So, I reinstalled I tried not to get ahead of myself and do things in a good order . 1st thing , upgraded kernel to 6.4 had no problems ; next did all updates- after restarting . while I was in the live install disk I did a lsusb and the new wifi adapter showed up ; and it shows up right now at bus 001 .
after updates did some setting up and now I need to ask the best way to install the driver that came with the adapter - the .sh install file I have or would it be better to just enable the AUR and install either of those ?

oh , there is 1 thing going on with my network manager or maybe just the icon or the applet ?
the icon is the one that shows up for when you’re NOT connected and when I click on it nothing at all happens but I obviously am connected to the internet thru the wifi ; and it connects automatically when I boot up . maybe this is a known bug , I haven’t checked yet .

A packaged format is preferred.
This way its integrated better with the system and will receive updates.

But I’m not sure what you are referring to installing?
You say networking works already?

With kernel 6.4 it should work plug and play. Verify with inxi. And then maybe rightclick on the icon. I don’t use cinnamon, but it is rightclick on xfce.

Yes, I have wifi internet with the adapter that is old. I bought a new one because I thought it might work better. I’m always only getting 60-80% of signal -? . so the only problem now is to install the right driver or package for RTL88X2BU - there are 2 rtl88 pkgs in the AUR – I don’t know which is best or if both are needed . ???