Insecure Permissions Error printing to RICOH

Forget about ll as:

So what were the exact steps you took to install the printer and what are the exact error messages and how is it connected? (USB, network, …)

Please provide more info because now all we know is “It’s not working” which doesn’t help us help you.


Hi again;

Ok I will write you exactly what I have done, step by step:

  1. I went to localhost:631 and logged into the CUPS as admin.
  2. Administration/Add Printer/Local Printers/Ricoh Sp111… When it asks me to choose the printer driver from the list, I chose the other option: “Add a ppd file manually”; because the driver for my garbage printer is not in the list. So I added the ppd file from github:
    GitHub - alysogorov/Ricoh_Aficio_SP1XX_CUPS_driver: CUPS driver for Ricoh Aficio SP1XX printer(possibly works for SP2XX)
  3. After setting up the ppd file, CUPS was giving error as “usr/lib/cups/filter/ricoh-sp1xx” no such file or directory.
  4. So, I moved each copies of the file “ricoh-sp1xx” and “ricoh-sp1xx.ppd” files to usr/lib/cups/filter
  5. When I check CUPS again, this time it gave another error which was the main reason I opened this topic: Idle - “File “/usr/lib/cups/filter/ricoh-sp1xx” has insecure permissions (0100755/uid=1000/gid=1000).”
  6. I found the following command via google search and applied it: sudo chown root:root /usr/lib/cups/filter/ricoh-sp1xx (The command was exactly the same except the file name in the end, so I changed it as my file name)
  7. After these steps, errors were gone. When I check CUPS I was able to see this: Ricoh Aficio SP 1xx, Status (Idle)
  8. So I thought it was ok; but whenever I try to print something, the printer were acting like it was done but without any action:
    – Print this word file
    ++Printing (???)
    Although the software says it took the command, I think it wasn’t transfering it to the printer.
  9. I tried to print test page and so on. After I was sure of that I wouldn’t able to proceed, I thought that maybe the problem was with the ppd file.
  10. So, I removed everything regarding my printer and restarted the laptop.
  11. I did the exact same processes with the previous setup, except I used another ppd file which was working when I tried on my Ubuntu, maybe 3-4 years ago, the link is:
    GitHub - madlynx/ricoh-sp100: CUPS driver for Ricoh Aficio SP 100 familty printers
  12. After I pass errors and restart the laptop now when I check CUPS I see:
    Ricoh Aficio SP 100, pstoricohddst-gdi 0.5 alpha, Status (Idle)
  13. But just now, when I try to print something I get this: Ricoh Aficio SP 100, pstoricohddst-gdi 0.5 alpha Processing - “Waiting for printer to become available.”

Note: By the way, my printer is plugged to my laptop via USB port.

I hope this will help you understand my problem. Waiting for your return.
Thank you.

You only need RICOH_SP1XX.ppd unless you want to test the driver (let’s forget about that and assume the driver is working) so:

sudo rm /usr/lib/cups/filter/ricoh-sp1xx

That might be because the printer isn’t hooked up to anything: it works and then doesn’t send the spool file to the USB port. I’m missing that bit.

Same issue as 8.

So please do the following:

  • I’m assuming you’ve already copied the RICOH_SP1XX.ppd and removed any of the other files you copied and made root the owner.
  • Go to the application launcher
  • type printer sett
  • Click on Printer Settings
  • In the printer settings application, click Unlock if needed
  • Click Add printer

Does your printer now show up in the Select Device list?

If yes: add printer and it will be connected to the USB port and happy printing!
If no: Please try another USB cable and see if it becomes available then.
If still no, please provide feedback.


Ok, so I removed everything and after that followed your steps. I get this error. So I will move a copy of the file into the /usr/lib/cups/filter/ should I or else?

And this is what CUPS saying:

1 Like

Don’t move! Never move! That will inherit the permissions of the original owner of the file and a problem you’ve already run into! :innocent: instead:

sudo cp /home/Whatever/Downloads/pstoricohddst-gdi /usr/lib/cups/filter/ 

Then feed back again, please…

1 Like

Ok, now printer status:

And this is when I try to print a test page:

It is indeed connected to USB and nothing is coming out.

Do you have another USB cable you can try?


Good morning Fabby :slight_smile:

Well, I don’t have another cable for printer; but I can buy. However, if the problem is with the cable how come the printer worked in Windows flawlessly?

Btw, I opened a bug report in github.

Another interesting point is this:

  1. If I setup sp100 ppd the error is “waiting printer for become available”
  2. if I setup sp 1xx ppd the error is “stopped, filter failed”

While any other variables are the same, errors changes. Does it not represent that the problem is with ppd? Correct me please if I am wrong.

Not a cabling issue if the printer currently works in Windows.

Please keep us informed about the bug report on Github as I’ve never seen this before.


Hi Fabby,

My problem continues and there is no return from gitHub. My printer worked in Windows; so if I install KVM and try to print do you think it works or not?

@Easthee As you seem to have a printer of the same brand. Could you have a look into this thread? (USB-connected RICOH)

1 Like

Hello @Fabby @Stockfish,

I would love to help, if I were able to, if I had that knowledge but I am afraid I will barely can help, if at all.

@Stockfish please read my short uber simple guide on installing Ricoh on Manjaro at the link, but I as far as I can see reading over this whole thread you may have some low OS level issue already (maybe some messed up permission/access issues too). If people here and my simple guide neither could help than I am afraid you may better do a reinstall and start from scratch (if you dont have a Timeshift backup for recovery).

I also struggled with my Ricoh (network connected) for weeks and only the above steps helped (the AUR package for my model and the PPD file from as per the links in my “guide”.

Today morning, I had been struggling again with another laptop with the same Ricoh, now an openSUSE Leap and I gotta admit that I did sweat blood with it and had spent like 5 hours to get the first page out of it… I love Linux but I do hate it too because of printing compatibility and issues, it is now my worst nightmare to install a printer on Linux, I would rather install a Gentoo linux than try to install a printer on Linux :smiley:
Linux simply hates printers, does not want to print on paper. Period :smiley: Sorry.

Hopefully you will solve it somehow but I am noob for this. In your shoes I would reinstall and setup Timeshift with Rsync full OS + /home backup (including hidden files) and than start with the printer and if anything goes wrong (just a non working line in terminal) I would immediately restore the system and start over.

1 Like

…oh, and the hundreds of various packages, fixes, solutions, approaches, driver replacement or adaptor solutions, thousands of commands and guides out there do not help us with all this, just make all this worse. I know, sorry. I feel your pain.

Hello @Easthee

Thank you for your fast return. I really don’t want to do a fresh install; because I have tons of GB’s installed games, programs etc. However, I will follow your guide and give you the feedback. I hope it works.

Well, the problem is not about my laptop hardware; because I have i7 processor with 16GB ram. I think the problem is with my ppd file. We’ll see. Tomorrow I will follow your guide.

Btw, I think my printer is a garbage. I didn’t have extra money for a printer at the time; so I bought the cheapest one. The next time I want to buy a Kyocera printer; which is not only an amazing printer but also has 100% linux support. All I need is to save the day for now.

See you tomorrow :slight_smile:


Fingers crossed. I am curious.

Let me know if you find a B&W which out of the box prints 100% on any Linux distro :smiley: I think those are HPs (the worst company I know and I will never have them or maybe…). Only HP has dedicated LINUX printing software, even a special HP printer management app for Linux. As far as I see Epson also has better support and Brother, Ricoh may be the worst with Linux (I got both :D) Frankly speaking, the lower cost per page printers with good refill potential are not easy with Linux while the most expensive HP is the best with Linux. I guess I understand this, the more money in a business, the more they invest into it (and a top Debian grandfather worked at HP too for years…).When I bought these two printers I was on Windows so it was okay, now on Linux I would buy different brands or models.

1 Like

Hi @Easthee

Well, It didn’t work; because does not have my ppd file. So, I wasn’t able to download it. However, I discovered something else.

I built ricoh-sp100-git from AUR and then I was able to choose the printer ppd file from the installing list and it installed without any errors. But now when I try to print something, the printer pretends like it prints the file; however it doesn’t grab the A4 paper and it completes the printing but It doesn’t print anything.

So, my conclusion is that it’s all about the ppd file. This file is supposed to work around 2 years ago and now I think it needs a revision. By the way, It is worth noting that the printer reacted for the first time when I tried to print something.

I will try to experiment on ppd files and try to make it work myself; unless I lose my sanity.

1 Like

Read this instead:



Nothing to worry than because I think you now did it already, those AUR packs do some black magic! :wink: That how it started to me as well, empty pages or 6 empty pages instead of one single page etc. My final solution was to install DIFFERENT PPD file, another Ricoh model’s PPD file for my Ricoh!

You also have to try many other PPD files, which are for similar models as yours (perhaps newer ones will rather work than older ones due to backward compatibility, by nature).

I am using the "Ricoh SP320SFN PLX " PPD driver for my Ricoh SP311SFN (which normally uses PCL5 too),. I tried the SP320SFN too but that printed empty pages or so. And many others…

LOL That title! So true! You just nailed it, bang on! That is what “we”, (ex)Win users feel, that is exactly how I felt just 2 weeks ago. I was the PC guru magician in my circles for decades, since my childhood while on Windows and now on Linux… I felt like a baby who cannot even walk alone. But if Win Wizards can learn, pickup Linux stuff extremely fast.
less than a month ago I could not even imagine living without Windows and I was sure it is impossible to leave behind some games and apps etc. And now here I am with a Win10 installer USB in my hand wondering if I really shall install it on an empty secondary partition just for a few hours usage a week for Apex Legends, maybe BF4 and for sure for my Sierra Chart online trading app and for Adobe Lightroom and Bridge for a while…