Insecure Permissions Error printing to RICOH

Hi all,

I am trying to install my printer but I’m getting following error:

Idle - “File “/usr/lib/cups/filter/ricoh-sp1xx” has insecure permissions (0100755/uid=1000/gid=1000).”

Could you please help?

What’s the output of

ll /usr/lib/cups/filter/


Hi Fabby,

That code gave me an error as “command not found”; but I solved the issue with the following command:

sudo chown root:root /usr/lib/cups/filter/ricoh-sp1xx

So, I was able to setup the printer; but it did not work. Then I tried another ppd from github.

This time, When I try to print a file, I am getting following error:

“Waiting for printer to become available.”

I am going crazy. I have tons of files to print and don’t have much time left :frowning: Any help would be highly appreciated.

I suspect you’re using an alias? :wink: … same (or similar) issue here, but different printer so will start a new thread when I get round to reconnecting the network downstairs (where the printer is). :smiley_cat:

That’s like the first alias I make on any system I’ve managed over the last… Meh, probably longer than you’re alive…

alias ll='ls --all -l --classify --human-readable'


1 Like

I’m going to sleep pretty soon, but tell us exactly what you’re doing as I’ve never had a printer not working (yeah: colours being off, wrong paper size, … but never “not working”)


İt was in the mode “idle” as it is supposed to be; but whenever I tried to print something the printer didn’t react. It was like software didn’t command to the printer. So I deleted previous installation and made a fresh install. And this time I used a tested ppd file in the past. I myself used it also; but today it is not working. Saying “waiting the printer bla bla” No action.

I put “alias” at the beginning if that’s what you’re expecting. I’m not good in these codes, I barely understand it. Here is the output:

alias ll /usr/lib/cups/filter/
bash: alias: ll: not found
bash: alias: /usr/lib/cups/filter/: not found

Is it correct or did I misspelled again?

The “alias” is something Fabby has added to his system to effectively use a “shortcut” for a command. It’s what I also do for commonly-used stuff in the Terminal e.g. if I type “speedtest” it runs wget -O - | python :wink: (I put it in my ~/.bashrc but it’s better to have a separate file if you have more than a few aliases) … e.g.:

alias speedtest='echo "wget -O - | python" && echo "" && wget -O - | python'"" && wget -O - | python'

Hope this clarifies things a bit. :smiley:

Thank you very much for the explanation :slight_smile: But I don’t need shortcuts atm, what I need is to make this printer work; or I will throw it out of the window soon :slight_smile:

Btw, last week when I had windows it was working. So the problem is with how I set it up. Do we not have printer experts here, I am in agony :slight_smile:

Forget about ll as:

So what were the exact steps you took to install the printer and what are the exact error messages and how is it connected? (USB, network, …)

Please provide more info because now all we know is “It’s not working” which doesn’t help us help you.


Hi again;

Ok I will write you exactly what I have done, step by step:

  1. I went to localhost:631 and logged into the CUPS as admin.
  2. Administration/Add Printer/Local Printers/Ricoh Sp111… When it asks me to choose the printer driver from the list, I chose the other option: “Add a ppd file manually”; because the driver for my garbage printer is not in the list. So I added the ppd file from github:
    GitHub - alysogorov/Ricoh_Aficio_SP1XX_CUPS_driver: CUPS driver for Ricoh Aficio SP1XX printer(possibly works for SP2XX)
  3. After setting up the ppd file, CUPS was giving error as “usr/lib/cups/filter/ricoh-sp1xx” no such file or directory.
  4. So, I moved each copies of the file “ricoh-sp1xx” and “ricoh-sp1xx.ppd” files to usr/lib/cups/filter
  5. When I check CUPS again, this time it gave another error which was the main reason I opened this topic: Idle - “File “/usr/lib/cups/filter/ricoh-sp1xx” has insecure permissions (0100755/uid=1000/gid=1000).”
  6. I found the following command via google search and applied it: sudo chown root:root /usr/lib/cups/filter/ricoh-sp1xx (The command was exactly the same except the file name in the end, so I changed it as my file name)
  7. After these steps, errors were gone. When I check CUPS I was able to see this: Ricoh Aficio SP 1xx, Status (Idle)
  8. So I thought it was ok; but whenever I try to print something, the printer were acting like it was done but without any action:
    – Print this word file
    ++Printing (???)
    Although the software says it took the command, I think it wasn’t transfering it to the printer.
  9. I tried to print test page and so on. After I was sure of that I wouldn’t able to proceed, I thought that maybe the problem was with the ppd file.
  10. So, I removed everything regarding my printer and restarted the laptop.
  11. I did the exact same processes with the previous setup, except I used another ppd file which was working when I tried on my Ubuntu, maybe 3-4 years ago, the link is:
    GitHub - madlynx/ricoh-sp100: CUPS driver for Ricoh Aficio SP 100 familty printers
  12. After I pass errors and restart the laptop now when I check CUPS I see:
    Ricoh Aficio SP 100, pstoricohddst-gdi 0.5 alpha, Status (Idle)
  13. But just now, when I try to print something I get this: Ricoh Aficio SP 100, pstoricohddst-gdi 0.5 alpha Processing - “Waiting for printer to become available.”

Note: By the way, my printer is plugged to my laptop via USB port.

I hope this will help you understand my problem. Waiting for your return.
Thank you.

You only need RICOH_SP1XX.ppd unless you want to test the driver (let’s forget about that and assume the driver is working) so:

sudo rm /usr/lib/cups/filter/ricoh-sp1xx

That might be because the printer isn’t hooked up to anything: it works and then doesn’t send the spool file to the USB port. I’m missing that bit.

Same issue as 8.

So please do the following:

  • I’m assuming you’ve already copied the RICOH_SP1XX.ppd and removed any of the other files you copied and made root the owner.
  • Go to the application launcher
  • type printer sett
  • Click on Printer Settings
  • In the printer settings application, click Unlock if needed
  • Click Add printer

Does your printer now show up in the Select Device list?

If yes: add printer and it will be connected to the USB port and happy printing!
If no: Please try another USB cable and see if it becomes available then.
If still no, please provide feedback.


Ok, so I removed everything and after that followed your steps. I get this error. So I will move a copy of the file into the /usr/lib/cups/filter/ should I or else?

And this is what CUPS saying:

1 Like

Don’t move! Never move! That will inherit the permissions of the original owner of the file and a problem you’ve already run into! :innocent: instead:

sudo cp /home/Whatever/Downloads/pstoricohddst-gdi /usr/lib/cups/filter/ 

Then feed back again, please…

1 Like

Ok, now printer status:

And this is when I try to print a test page:

It is indeed connected to USB and nothing is coming out.

Do you have another USB cable you can try?


Good morning Fabby :slight_smile:

Well, I don’t have another cable for printer; but I can buy. However, if the problem is with the cable how come the printer worked in Windows flawlessly?

Btw, I opened a bug report in github.

Another interesting point is this:

  1. If I setup sp100 ppd the error is “waiting printer for become available”
  2. if I setup sp 1xx ppd the error is “stopped, filter failed”

While any other variables are the same, errors changes. Does it not represent that the problem is with ppd? Correct me please if I am wrong.

Not a cabling issue if the printer currently works in Windows.

Please keep us informed about the bug report on Github as I’ve never seen this before.


Hi Fabby,

My problem continues and there is no return from gitHub. My printer worked in Windows; so if I install KVM and try to print do you think it works or not?