Ink app to display printer ink levels

I have been using the “ink” app to display the ink levels for my canon ip4700 printer. After some recent updates the app does not work and displays the error message “segmentation fault sudo ink -p usb” whenever I try to use it. The app worked for some time then problems occurred after some updates. I have checked and the app continues to work fine under linux mint but not in Manjaro linux. Anyone have ideas as to why?

One could suspect the app needs to be rebuilt against the new qt libs or if no dependency on qt perhaps just rebuilt.

Just took a look at the source - it doesn’t look like depending on qt.

When you update the system - any custom library may cease functioning and thus you need to rebuild the library.

Do a clean build - that is if you have the previous source cached then remove it and rebuild the package.

Just to clarify, [linux-aarhus, if I uninstall ink using Pamac will that clear any source cache or must I remove it some other way? I have tried uninstalling ink then re-installing it without success.

Uninstalling will not remove sources downloaded for building purpose.

Pamac caches build sources in /var/tmp/pamac-build-$USER tree.

Thank you very much I will try that.

OK, I uninstalled ink, deleted the previous sources file as suggested then re-installed ink but continue to get the same error message “segmentation fault sudo ink -p usb” when I try to run it.

I just installed it and the ink binary runs fine. I suggest a clean rebuild of libinklevel then ink.

I have the same error.
Rebuild (clean) is not the Solution.

Can you please check this command
ink -p usb

Why did it work for me, then? It’s something on your end.

I don’t have a compatible device, but the output seems proper:

Could not get device id.
Could not get ink level.
zsh: segmentation fault (core dumped)  ink -p usb

The Printer is offline

kernel: ink[12319]: segfault at 38 ip 00007fddb70a08a4 sp 00007ffcf2b05918 error 4 in[7fddb703c000+176000]

and then coredump

Not sure what to tell you then. I am using the Manjaro unstable branch, so that could make a difference.

Remember, using the AUR is neither supported by Arch nor Manjaro. AUR package maintainers build against Arch stable and users are expected to be up to date. The Manjaro unstable branch is normally less than a few hours behind Arch stable at most.

With today’s stable update the problem is solved

ink -p usb                                                                                                                                        
Could not get device id.
Could not get ink level.

Printer is offline