Initramfs unpacking fail -- can't boot into system after update

Dear All,

kindly see below picture. (I don’t know how else to post this with the forum beginner rules. So sorry for the space after the dot)
[boot error screen] (https:// imgur. com/ls13qZr)
This occurs straight after boot when I select the grubx86.efi from the refind menu. The refind and boot partition seem to be working just fine otherwise (for the dual booted windows for instance).
This is what I’ve done to try to remedy the situation:

  • booted into the most recent manjaro-i3 iso from usb,
  • manjaro-chrooted into the non-booting system,
  • Updated linux (kernel 5.13 on the system), udev and mkinitcpio.
  • Ran mkinitcpio -P , no problems, (checked if the initram files for the kernels in /boot were new), also updated grub. I even re-installed grub for efi.

No changes.
The system runs on an AMD Ryzen 9. Is it a problem that the chroot kernel is 5.13 (and system kernel, too, before I updated to 5.14 in the chroot for good measure) and hence the mkinitcpio doesn’t like it after the update? Or should I manipulate the compression format? It’s a normal FAT-boot partition, so to say. Also, I haven’t checked the log files from the update yet I must confess. Whenever I had a similar issue, rebuilding as above was sufficient.

Really appreciate any help,
since I don’t really want to re-install right now ^^
Kind regards,
Robert

I’ve no experience with refind but since you wrote “after update” I’m assuming your setup worked before (and this is not a mis-configuration of refind).

Looks like a botched initramfs. Try

  • booting from usb
  • manjaro-chroot -a into your installation
  • run mkinitcpio -P again

Best also install linux510 (latest LTS kernel) while you’re at it, so you have a fallback kernel/initramfs in the future:

$ sudo mhwd-kernel -i linux510

you should have :

  • kernel 5.10 LTS installed
  • kernel 5.14 installed
  • kernel 5.15 installed

==> with Refind which one will be chosen ?

version 5.13 is EOF ( end of Live – no more support from Stable kernel )
https://www.kernel.org/category/releases.html

Thank you for the tips! Sorry for the late reply but I had full work days.

I’ve booted into the XFCE live iso that comes with kernel 5.15, chrooted and installed kernels 5.10, 5.14 and 5.15 as suggested. Also removed any others + then rebuilt the initramfs with mkinitcpio -P.
Unfortunately, the problem persists. I’ve then played around with different compression formats. If I use zstd, for instance, I only get a black screen, same for xc. If I leave it uncompressed (via ‘cat’), it gives the same error as originally. If I erase all initramfs it complains about none being there, so at least that seems to “work”. Thus, I’m now wondering:

  1. could there be any issue with a compression package and which would that be?
  2. why isnt Grub sending me to the Grub menu first (like before the update/reinstalls of initramfs and Grub) to select the kernel but apparently trying to immediately go for an initramfs without user consultation, so to say.

I’ve looked at the grub.cfg but it seemed fine to me. Can post it, of course if you think it might be useful. I feel like I’m running out of tricks a bit, so very glad for any other ideas.

Best wishes all