Incorrect ligatures with Noto Sans (seen e.g. in thunderbird)

Something strange has recently started to happen with the “mail compose” window in thunderbird. When I type something, ligatures are substituted for some letter combinations (e.g. ffi, ffu and so on). The problem is that these ligatures are wrong! For instance ffi becomes “ffl”, while ffu becomes “fiu”, making the text hardly readable.

The problem goes away if I change the default font in thunderbird from “sans serif” (that automatically maps to Noto Sans) to other sans serif fonts even if these still include ligatures that are automatically applied (e.g. Source Sans 3).

Is the Noto Sans currently distributed with Manjaro in /usr/share/fonts/noto/NotoSans-Regular.ttf broken? Or is there some issue with the font renderer which gets triggered by Noto Sans?

there are some license-restrictions that linux isn’t supporting some fonts by default. you’ll need to install them manually. search for avaiable fonts at the package manager. a helpful link for infos might be here:

I think that there is a misunderstanding, my problem is not about fonts that are not part of the standard Manjaro install. The other way round, it is about a font — Noto Sans — that is very much part of the standard Manjaro offer, to the point of being the default sans serif font on the system.

The problem is that after the last upgrades (would not be able to say whether it was the last one or the one immediately before) this font has started to misbehave wrt ligatures.

I can’t reproduce this.

This is how it looks here:

Are you writing HTML or text email and which font did you choose exactly?

OK, I have already identified and solved the issue. It is the same as in here: Ligatures seemingly enabled by default, causing broken text in some places. · Issue #1583 · notofonts/noto-fonts · GitHub

Looks like the font renderer does not like it at all when some font is changed behind its shoulders, so you get misrenderings until the font renderer is shut down and restarted (by rebooting or at least by restarting the graphical session, e.g. by restarting sddm).

If this is the case, probably an advice to restart the graphical subsystem should be given when font files that are in use get modified by some system update.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.