Incorporating wine into the main system with Distrobox

Hi. I have an .exe installer that I used to be able to run but now I can’t. I can run this file with wine on ubuntu but not with wine on manjaro. I created an ubuntu container with distrobox and separated the home folder of this container. I installed wine on ubuntu. Now how can I transfer this wine to manjaro. When I type wine --version from the terminal, I want it to detect wine on ubuntu

I knew nothing about the existence of distrobox until this moment.

Perhaps you can find information on how to do what you want to do here:

Distrobox - ArchWiki

If you have wine installed in your system
I cannot see how running some .exe would not be possible.

wine uses prefixes - if you don’t specify a prefix, the default is ~/.wine

You could therefore probably simply copy this directory from your ubuntu home to your Manjaro home
(adjust ownership and permissions perhaps)

wine --version
will simply print the version of wine you have installed in Manjaro

What happens when you run:

wine ~/path_to_your_exe_file/xyz.exe

1 Like

You can also test bottles. It allows easily managing different wine prefixes, and more importantly, you can set a different wine engine on each bottle. Effectively allowing you to run older wine versions or tuned up versions like proton ones on manjaro which by default will run the latest wine.

1 Like

yes - I was going to suggest this, too.
Distrobox seems to be just about the most complicated and convoluted way humanly possible to approach this … issue. :nerd_face:

Thank you, I solved my problem. With

distrobox-export --bin usr/bin/wine --export-path ~/.local/bin

with the code above I included wine from ubuntu in Manjaro.

but I have a question, the version of wine in Ubuntu is 6.0.3 and the version in Manjaro is 9.9-2. How can I install wine version 6.0.3 on manjaro ? I’m not very good with Linux and I try to solve simple things in the most complicated ways unfortunately :frowning:

Unfortunately, the application I installed with the bottles application does not detect the video cards on my system. I had intel and nvidia cards in my system, I was using the nvidia-470xx-dkms driver.

You don’t need to.
What you (apparently) did was to export the wine binary into your ~/.local/bin
which is unlikely to work because of … everything else it needs is missing.

What you want to have is the ~/.wine directory - that is where your application is
and almost any wine version can likely run it.

read the above posts - what @Teo said - and also mine

1 Like

what I really wanted to do was to install a game on Manjaro. My wine version on manjaro was 9-9-2 and when I tried to install the dependencies that the game needed with this wine it gave me an error. dependencies like nvidia-physx and vcruntime 2008. But interestingly version 6.0.3 of wine in the ubuntu repositories installed these dependencies without any problems. I actually solved my problem now. But I would have been happier if I had only managed to install an older version of wine on manjaro and not in such a complicated way. Thank you all


bottles and perhaps playonlinux could/should have been able to do that for you

I tried bottles but the game didn’t detect my video cards. I’ll try playonlinux. My English is a bit bad, but my problem was that the game didn’t work with wine on manjaro but with wine on ubuntu. So I installed ubuntu container with distrobox and now I am using wine from ubuntu repositories.

ok - I just wanted to know how you ended up doing it - I like to learn and I had never before heard of distrobox.
It is another tool that may come in handy some day.
One can’t use tools one does not have or does not even know about …

Okay, I’ll tell you.

  • I installed the podman package
  • I installed the distrobox package
  • I created a container named ubuntu-db with distrobox-create --name ubuntu-db --image ubuntu:22.04 --home ~/ubuntu-db/ --nvidia
    I installed version 22.04 of ubuntu in this container. I set the home folder of this container as the ubuntu-db folder. I added --nvidia at the end of the code to include the video card driver I used in the manjaro in the container.
  • Then I logged into the container with the code distrobox-enter ubuntu-db
  • Here it made some adjustments and I waited a bit.
  • I installed the necessary programs with sudo apt install wine wine32 winetricks
  • With these codes below, I added the wine winecfg and winetricks programs in the Ubuntu container to the manjaro
distrobox-export --bin usr/bin/wine --export-path ~/.local/bin
- distrobox-export --bin usr/bin/wine --export-path ~/.local/bin
distrobox-export --bin usr/bin/winetricks --export-path ~/.local/bin
- distrobox-export --bin usr/bin/wine --export-path ~/.local/bin
distrobox-export --bin usr/bin/winecfg --export-path ~/.local/bin
- distrobox-export --bin usr/bin/wine --export-path ~/.local/bin

distrobox-export --app winetricks

  • So when I double click on a file on the desktop, the wine in the ubuntu container is now activated and works with that version of wine. I admit this is the longest and most tedious way to solve this problem :smiley:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.