In gnome 42, when applying a dark theme, dynamic wallpapers do not work

I recently upgraded to the new version of gnome 42. Of course, I realized that this is a test branch of updates, and something will not work on it. everything works surprisingly well, however, after the update, dynamic wallpapers stopped working. I searched for information on the Internet, tried to set it up myself, but the wallpaper with xml resolution could not be installed. the situation is unpleasant, but I reconciled myself and put a static wallpaper and continued to use it, and today I noticed that if you put a light theme in the system settings, then the dynamic wallpaper magically starts working. Accordingly, with a dark theme, only a static picture can be installed on the desktop. Who knows what can be done in this case? Because I really want to get back dynamic wallpapers and continue using the dark theme. For mistakes, please do not hit, I translated in a translator from another language :slight_smile:

Welcome to the forum! :wave:

In what way?

What exactly are you trying to install and how?

Dynamic wallpapers can still be used. It will apply to both the Light and Dark system theme.

Well, while I had GNOME 41, I made myself a dynamic wallpaper like on a MAC BOOK, namely: they change depending on the time of day. However, after updating to GNOME 42, they stop working. I just have a file with dynamic wallpaper stopped being installed on my desktop.
In GNOME tweak it is indicated that they are installed, but in the GNOME settings themselves they are set to a light theme, in a dark theme, the default wallpaper works. I wanted to attach screenshots, but for some reason I can’t, probably the account is just new.

Yes, I’m familiar. We even have a Manjaro version: manjaro-dynamic-wallpaper. We also have Dynamic Wallpaper Editor in our repos.

What file?

You just said…

Do you see your dynamic wallpaper in the Appearance section?

Try installing manjaro-dynamic-wallpaper and see if it appears there. It does for me.

I saved the dynamic wallpaper in an .xml file and installed it through GNOME tweeks

I also tried it through manjaro-dynamic-wallpaper, they are installed, but in the options, in the “appearance” tab, they are only available in a light theme for some reason. the dark theme only shows the default wallpaper or static pictures. I would throw off the screenshots, but only the level of trust is low (

I uploaded screenshots to Yandex disk, I hope it will not be a violation if I upload the link in this way, because this is not a malicious link (just remove the space between //, and between - - and the link should work):
https:/ /disk.yandex.ru/d/R- -JKp8KaSLEeA

Same issue here, dynamic wallpaper working properly when light wallpaper selected, not when dark selected.
Feel free to ask for more information

It’s true for me as well. Dynamic wallpaper works with light theme, but doesn’t work with dark theme.
I found a workaround, though.

  1. Install manjaro-dynamic-wallpaper package
  2. go to /usr/share/gnome-background-properties, find the file manjaro-time-property.xml, create a copy of it with some new desirable filename (let’s say dynamic.xml)
  3. open the new file (dynamic.xml) and replace two paths in “name” and “filename” tags so that they would point to your dynamic wallpaper xml file that you previously created with Dynamic Wallpaper app.
    save the file.
  4. Open gnome settings and go to the Appearance section.
  5. Switch to light theme and close the settings window
  6. Open the settings window again, now you will see your dynamic wallpaper appear in the bottom next to the manjaro dynamic wallpaper. Select your dynamic wallpaper. The background should change to the first image from your image sequence.
  7. Scroll up and select Dark theme again in gnome settings. Close the window.
  8. If the picture looks weird (too stretched, for example), you can change the adjustment options in Dynamic wallpaper app (under the “apply” menu) to the desired one. Just launch the app and change the option.

it can also be done with dconf editor in a much easier way

1 Like

Thanks this was really helpful. I really wanted to try the dynamic wallpaper but cant also live without dark mode. This workaround worked wonders!!!