Impossible to launch application via shortcut with non-english keyboard layout

I can’t launch any application via shorcut if current keyboard layout is not English. Earlier I was able to do it, but now I am not.

For example, I can’t launch Web Browser with Super+W, because XFCE interpret it as Super+Ц.


So before recent update I was able to launch browser with Super+W (where ‘W’ is not literal ‘W’ symbol but numerical code of ‘W/Ц’ button)

Now in order to launch browser I have to

  1. Press Super+Ц
  2. Wait for some time, then realize that nothing was launched
  3. Switch keyboard layout to English
  4. Press Super+W once again

How to fix that problem?


I do not know whether this is a way to do this,
but I noticed that I have, for some apps, two shortcuts defined for the same action.

For instance for
exo-open --launch WebBrowser
I have two, one key is the “HomePage” key and the second set to use the “Internet” key.
… none of these keys exist on my keyboard - this is the default setting for my installation
I never use hotkeys anyway - I use the whisker menu - the windows key brings it up, and then I start typing, it usually only takes one keystroke.
A bit like rofi.

This is what my default looks like:

exo-open --launch WebBrowser --> Internet
exo-open --launch WebBrowser --> HomePage

Perhaps you can set one hotkey using the english layout and another for the kyrillic one?

There are members here that, like you, use two keyboard layouts - they might know.

Thanks for your answer, but it’s not a solution.

Yes I can duplicate every command like

exo-open --launch WebBrowser --> Super+W
exo-open --launch WebBrowser --> Super+Ц

but this is stupid.

I have long list of shortcuts for every application I use (browser, text editor, file manager, image viewer, IDE, terminal/console, task manager, telegram messenger, tor browser, mail client, system update, printscreen). And now I have to make this list twice long.


Well, if it used to work but now it doesn’t anymore
then I do not have a solution.

Someone else might know. I don’t.

But if this works - and if I need it to work - I’d probably do it and be done with it.

Sorry that I could not help!