Impossible to change the manjaro KDE wallpaper with deepin

I installed Deepin with my manjaro kde. Everything works fine. Except one thing. I can’t change the background. I tried several methods, but I can’t do it.
Does anyone have a solution? Thank you.

You could have just installed the deepin-community-wallpapers package and then from the KDE Plasma Desktop and Wallpaper settings just add the image you want from /usr/share/wallpapers/deepin/ … How is that not working for you?
What exact desktop session are you loading?
Also, i would have never mixed KDE Plasma with Deepin …

I don’t know if it works in Deepin, but you can try with nitrogen a little app to change wallpaper under Icewm and those kind of WM

I Have the deepin-community-wallpapers in /usr/share/wallpapers/deepin/
but that doesn’t change anything. In deepin, when you right-click on an image, you can set it as background. But this doesn’t work either.
I tested with manjaro xfce + deepin and also manjaro kde + deepin.
I tried manjaro DDE. You can change the wallpaper but the themes don’t work.
What is the solution? I can’t find it. Thanks for your help.

Sorry for a late answer. I’ve had this problem for quite a while. It seems to me that changing the wallpaper depends on deepin-kwin. But sadly that package at least for me is broken now so I have to use deepin-wm as the alternative window manager. So you cannot change the wallpaper if you are using Deepin WM, but only if you use kwin. The only way to make it work (assuming you have both deepin-wm and deepin-kwin installed, as I do since that is the only setup that is working otherwise for me) that I have found is to
pacman -R deepin-wm
Reboot, change the wallpaper right-clicking on desktop or some other way.
pacman -S deepin-wm

Welcome to Deepin.

Has anyone tried with setting the wallpapers from /usr/share/wallpapers or /usr/share/backgrounds?
(if it works then the ‘solution’ is to copy desired wallpapers to that folder and apply them from there)

Simple. Seems to work for me. :smiley: Which means that what I said before might not apply to the original problem. Because I could change it even from /usr/share/wallpapers/deepin. So it seems only changing the wallpaper from the desktop depends on deepin-kwin.

But if that doesn’t work, you could try removing deepin-wm though as stated above…

Yes, that’s how it works. I have installed manjarodde, and there is no problem with the wallpaper. But when I update I get a black screen. But I have no problem with manjaro. I even installed arch with deepin and it works. It’s a shame that there is a problem with manjarodde