iMac gpu driver issue (Radeon hd 2400 xt)

Hey there,
I tried to install manjaro kde on an old iMac. The installation went fine, but when I entered sleep mode and quit it again the whole screen had a red overlay and there were other artifacts visible.

I searched the internet and came to the conclusion, that it must be a driver issue of the gpu. So I installed alternative drivers in the kde settings application and rebooted. After the reboot the screen just showed dev/sda2: clean, n/n files, n/n blocks with the ns being some number. I tried to start x manually and to reboot but both didn’t work. Here is the x log file, please notice that I replaced links to the x website with (link):

[ 2753.029] (WW) Failed to open protocol names file lib/xorg/protocol.txt
[ 2753.032]
(link) X Server 1.20.11
X Protocol Version 11, Revision 0
[ 2753.039] Build Operating System: Linux Manjaro Linux
[ 2753.041] Current Operating System: Linux my_user_name-imac71 5.10.53-1-MANJARO #1 SMP PREEMPT Mon Jul 26 07:18:28 UTC 2021 x86_64
[ 2753.041] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 root=UUID=d73eadee-8dd7-4648-a6ba-9e95ba0e9adf rw quiet apparmor=1 security=apparmor udev.log_priority=3
[ 2753.046] Build Date: 13 April 2021 04:11:08PM
[ 2753.049]
[ 2753.051] Current version of pixman: 0.40.0
[ 2753.055] Before reporting problems, check (link)
to make sure that you have the latest version.
[ 2753.055] Markers: (–) probed, () from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 2753.066] (==) Log file: “/home/my_user_name/.local/share/xorg/Xorg.0.log”, Time: Sat Aug 7 19:28:09 2021
[ 2753.069] (==) Using config directory: “/etc/X11/xorg.conf.d”
[ 2753.071] (==) Using system config directory “/usr/share/X11/xorg.conf.d”
[ 2753.071] (==) No Layout section. Using the first Screen section.
[ 2753.071] (==) No screen section available. Using defaults.
[ 2753.071] (
) |–>Screen “Default Screen Section” (0)
[ 2753.071] () | |–>Monitor “”
[ 2753.071] (==) No device specified for screen “Default Screen Section”.
Using the first device section listed.
[ 2753.071] (
) | |–>Device “Device0”
[ 2753.071] (==) No monitor specified for screen “Default Screen Section”.
Using a default monitor configuration.
[ 2753.072] (==) Automatically adding devices
[ 2753.072] (==) Automatically enabling devices
[ 2753.072] (==) Automatically adding GPU devices
[ 2753.072] (==) Automatically binding GPU devices
[ 2753.072] (==) Max clients allowed: 256, resource mask: 0x1fffff
[ 2753.072] (WW) The directory “/usr/share/fonts/OTF” does not exist.
[ 2753.072] Entry deleted from font path.
[ 2753.072] (WW) The directory “/usr/share/fonts/Type1” does not exist.
[ 2753.072] Entry deleted from font path.
[ 2753.072] (WW) The directory “/usr/share/fonts/100dpi” does not exist.
[ 2753.072] Entry deleted from font path.
[ 2753.072] (WW) The directory “/usr/share/fonts/75dpi” does not exist.
[ 2753.072] Entry deleted from font path.
[ 2753.072] (==) FontPath set to:
[ 2753.072] (==) ModulePath set to “/usr/lib/xorg/modules”
[ 2753.072] () Extension “Composite” is enabled
[ 2753.072] (
) Extension “RENDER” is enabled
[ 2753.073] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[ 2753.073] (II) Module ABI versions:
[ 2753.073] (link) ANSI C Emulation: 0.4
[ 2753.073] (link) Video Driver: 24.1
[ 2753.073] (link) XInput driver : 24.1
[ 2753.073] (link) Server Extension : 10.0
[ 2753.074] (++) using VT number 6
[ 2753.076] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_35
[ 2753.077] (II) xfree86: Adding drm device (/dev/dri/card0)
[ 2753.078] (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 10 paused 0
[ 2753.084] (–) PCI:*(1@0:0:0) 1002:94c8:106b:0084 rev 0, Mem @ 0xc0000000/268435456, 0xd0620000/65536, I/O @ 0x00003000/256, BIOS @ 0x???/131072
[ 2753.084] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[ 2753.084] (II) LoadModule: “glx”
[ 2753.084] (II) Loading /usr/lib/xorg/modules/extensions/
[ 2753.087] (II) Module glx: vendor="(link) Foundation"
[ 2753.087] compiled for 1.20.11, module version = 1.0.0
[ 2753.087] ABI class: (link) Server Extension, version 10.0
[ 2753.087] (II) LoadModule: “vesa”
[ 2753.087] (II) Loading /usr/lib/xorg/modules/drivers/
[ 2753.087] (II) Module vesa: vendor="(link) Foundation"
[ 2753.087] compiled for 1.20.9, module version = 2.5.0
[ 2753.087] Module class: (link) Video Driver
[ 2753.087] ABI class: (link) Video Driver, version 24.1
[ 2753.087] (II) VESA: driver for VESA chipsets: vesa
[ 2753.087] xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
[ 2753.087] vesa: Refusing to run on UEFI
[ 2753.087] vesa: Refusing to run on UEFI
[ 2753.087] (EE) No devices detected.
[ 2753.087] (EE)
Fatal server error:
[ 2753.087] (EE) no screens found(EE)
[ 2753.087] (EE)
Please consult the The (link) Foundation support
at (link)
for help.
[ 2753.087] (EE) Please also check the log file at “/home/my_user_name/.local/share/xorg/Xorg.0.log” for additional information.
[ 2753.087] (EE)
[ 2753.094] (EE) Server terminated with error (1). Closing log file.

The computer runs a Intel Core 2 Duo T7300 and a AMD ATI Mobility Radeon HD 2400 XT.
The primal issue is not that I can’t log in, but that sleep mode doesn’t work. Since it’s a new installation I have no intentions in saving any data. Before installing manjaro I already tried out different distros, where similar issues occurred. Manjaro was the most stable of the distros I tried so far. I also searched multiple forums after iMac driver issues with linux but just found out, that amd apparently doesn’t support this gpu on linux anymore and that there are just the open source drivers.

If anyone has an idea how to get kde back running, and more importantly, how to get rid of the red screen, feel free to post your answer.

So you installed this one:

This driver has no graphical support, only basic video. So text-mode ^^

Switch to another TTY: CTRL + ALT + F3 and login there.

remove it again:

sudo mhwd -r pci video-vesa

and install the correct driver (if removed):

sudo mhwd -i pci video-linux

Maybe some of these options in Xorg could help: radeon(4): ATI/AMD RADEON video driver - Linux man page

Since it is an older card, use also an older kernel. The radeon driver is baked into the kernel.

sudo mhwd-kernel linux54

or even older… Here you get a list: mhwd-kernel --list


I was able to remove the driver I installed and to boot into kde plasma. However, the problem with the red screen is not resolved. I tried the kernels linux54 and linux414, which was the oldest listed by mhwd-kernel --list. Do you have any other ideas? Here is the output of mhwd -li, I figured it might be useful to you:

Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
     video-modesetting            2020.01.13                true            PCI
           video-linux            2018.05.04                true            PCI
   network-broadcom-wl            2018.10.07                true            PCI

I also had an error as I booted with the linux414 kernel, but plasma still started:

/dev/sda2: clean, n/n files, n/n blocks
[4.211488] cgroup: cgroup2: unknown option "memory_recursiveprot"
[16.114821] radeon 0000:01:00.0: Invalid PCI ROM header signature: expecting 0xaa55, got 0xd52a
[18.920131] kfd kfd: kgd2kfd_probe failed

Anyway, thank you very much, your help is appreciated.

For all of those who visit this post later on:
@megavolt forgot the --install flag in the last command:

sudo mhwd-kernel --install linux54

I ran it with the rmc option to remove the current kernel