iMac early 2009 doesn't get to grub at all when booting from live USB

Hi guys,

I am trying to try the live USB on a very old iMac early 2009 but I can’t get to the grub menu when I boot using the live USB. I get for a split second a message saying “Starting version 250.2-1-manjaro” and then the screen gets blank (it seems like it tries to load a driver, but fails) and I never get the boot menu.

With other distros I was able to add a nomodeset parameter to my boot, but here I can’t get to the grub screen at all. Is there a way I can change the iso with that param? Any other things I can try?

The iMac has a ATI Radeon HD 4850 card, which generally worked quite OK with a nomodeset param.



Neither by pressing Shift or Esc before it loads that message?
See here iMac (21.5-inch, Mid 2010) - ArchWiki as the same thing applies

Thanks @bogdancovaciu. Are you suggesting I should actually install it before trying it?

I’ll try though to press either Shift or Esc between selecting the USB medium in the menu (which I get by pressing Option right after the Mac’s sound) and getting the “Starting version 250.2-1-manjaro” message and I’ll report back.

@bogdancovaciu unfortunately pressing the Shift or Esc keys does not change the outcome. The message though doesn’t get displayed, so it may be that Grub executes without being displayed, but I am not sure how to bring that up at all.

Apple Boot has particular way to deal with another bootloader. In your case you would need The rEFInd Boot Manager
Or try this way from the options described here Mac - ArchWiki
But i would recommend to read that entire wiki article.

Thanks @bogdancovaciu, will read.

Just as a FYI I don’t have this problem with ArchLinux itself, grub loads correctly and I can pick a booting option.

If I’m correct we’re talking about an imac 9,1.
According to this post:

In life mode everything seems to work.’ (but issue dd vs etcher)
That was only 4 month ago and they boot, as you experienced with other distros, normally without issues. I’m writing this on a 2009 mbp, different hardware/no MacOS but same 64bit efi, boots manjaro isos fine without refit.

  • try different stick (seriously!)
  • check the way you burn (suse imagewriter works)
  • use the LTS iso with 5.10LTS kernel

Thanks @6x12 I will try your suggestions! You are correct, it’s a 9,1

I’ve been using balena etcher on a mac to burn the iso so far.

@6x12 I tried with a different stick, using both dd and etcher (on a mac) and I tried the LTS version (minimal LTS for both xfce and kde), but the result is the same.

If I just wait it looks like the first booting option is picked as I see for a split second “Starting version 250.2-1-manjaro”, but then the screen turns blank again.

Just booted via ‘options’ >> ‘yellow efi-boot’

  • manjaro-xfce-21.2.2-minimal-220123-linux515.iso
  • manjaro-xfce-21.2.2-minimal-220123-linux510.iso

and both work; broadcom wifi works.

yeah that is also how I tried to boot both those images

When booting from the usb there is, at least on my screen, no grub. After hitting the yellow ‘efi-boot’ screen stays dark for 25sec (ssd), then 'starting manjaro…and immediately a lot of boot info and up comes the desktop.


May sound pedantic but check the iso shasums…

Right, after I see the “starting majaro” message the screen goes blank again.

With other distros I got this exact behavior if I wasn’t booting in safe mode. I solved that problem by passing a nomodeset param to the kernel option (or there was one already with that param, a “Safe Mode” ) in grub.

Is there a way to change the content of the bootable iso to maybe add nomodeset to the first grub option? maybe that will allow the system to boot properly?

Found this on Imac/ATI Radeon HD 4850 iMac 27" RadeonHD4850 modesetting problem / Newbie Corner / Arch Linux Forums :

“It’s working with the open radeon drivers, but only when an external monitor is plugged into the minidisplay port. If I try to boot with the displayport unplugged I get the black screen on the internal monitor, but when plugged in both monitors work perfectly. You can even disable the external monitor in your Desktop Environment settings post-boot if you don’t want/need it.”

Interesting work around :grinning: . You can install, get your grub to pass nomodeset and edit the grub.cfg if all goes well.

Got a display and the adapter?

Thanks @6x12 I’ll have a look there as well!

I do have a display but not an adapter, so I will have to see how to try that. I am just trying to extend my old iMac life, so I also don’t want to go too crazy :smiley:

With an ssd they feel like contemporary devices; with the old notebook drive my mbp was too sluggish, your imac should still be usable with the fast spinner.

Good luck.

1 Like