iMac 2011 getting black screen

I really like Manjaro and have used it on my laptop.

On my iMac 27" 2011 with faulty AMD card, I have MX Linux 21 installed and running.

When i run from manjaro live usb, I get a black screen and grub menu is not visible. I have used different usb makers like balenaetcher, fedora writer and mxlive usb maker and had the same result.

As i cannot see the grub menu, cannot choose failsafe options.

Any help is greatly appreciated.

Below is system information.

System:    Host: <filter> Kernel: 5.10.0-8-amd64 x86_64 bits: 64 compiler: N/A 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.10.0-8-amd64 
           root=UUID=<filter> ro quiet nomodeset splash 
           Desktop: Gnome 40.2 wm: gnome-shell dm: LightDM 1.26.0 
           Distro: MX-21_beta1_x64 Wildflower July 27  2021 base: Debian GNU/Linux 11 (bullseye) 
Machine:   Type: Desktop System: Apple product: iMac12,2 v: 1.0 serial: <filter> Chassis: 
           type: 13 v: Mac-942B59F58194171B serial: <filter> 
           Mobo: Apple model: Mac-942B59F58194171B v: iMac12,2 serial: <filter> UEFI: Apple 
           v: date: 06/14/2019 
CPU:       Topology: Quad Core model: Intel Core i5-2400 bits: 64 type: MCP arch: Sandy Bridge 
           family: 6 model-id: 2A (42) stepping: 7 microcode: 2F L2 cache: 6144 KiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 24800 
           Speed: 1879 MHz min/max: 1600/3400 MHz Core speeds (MHz): 1: 1716 2: 1685 3: 1689 
           4: 1697 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled 
           Type: mds mitigation: Clear CPU buffers; SMT disabled 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass 
           mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, 
           STIBP: disabled, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics 
           vendor: Apple driver: N/A bus ID: 00:02.0 chip ID: 8086:0102 
           Device-2: AMD Blackcomb [Radeon HD 6970M/6990M] vendor: Apple driver: N/A 
           bus ID: 01:00.0 chip ID: 1002:6720 
           Display: x11 server: X.Org 1.20.11 driver: none unloaded: fbdev 
           compositor: gnome-shell resolution: 2560x1440~93Hz 
           OpenGL: renderer: llvmpipe (LLVM 11.0.1 256 bits) v: 4.5 Mesa 20.3.5 compat-v: 3.1 
           direct render: Yes 
Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio 
           driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:1c20 
           Device-2: AMD Barts HDMI Audio [Radeon HD 6790/6850/6870 / 7720 OEM] vendor: Apple 
           driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 1002:aa88 
           Sound Server: ALSA v: k5.10.0-8-amd64 
Network:   Device-1: Broadcom and subsidiaries NetXtreme BCM57765 Gigabit Ethernet PCIe 
           driver: tg3 v: kernel port: 2000 bus ID: 02:00.0 chip ID: 14e4:16b4 
           IF: eth0 state: down mac: <filter> 
           Device-2: Qualcomm Atheros AR93xx Wireless Network Adapter 
           vendor: Apple AirPort Extreme driver: ath9k v: kernel port: 2000 bus ID: 03:00.0 
           chip ID: 168c:0030 
           IF: wlan0 state: up mac: <filter> 
Drives:    Local Storage: total: 960.33 GiB used: 17.76 GiB (1.8%) 
           ID-1: /dev/sda vendor: Western Digital model: WD1001FALS-403AA0 size: 931.51 GiB 
           block size: physical: 512 B logical: 512 B speed: 3.0 Gb/s rotation: 7200 rpm 
           serial: <filter> rev: 1D02 temp: 55 C scheme: GPT 
           ID-2: /dev/sdc type: USB vendor: Kingston model: DataTraveler 3.0 size: 28.82 GiB 
           block size: physical: 512 B logical: 512 B serial: <filter> scheme: MBR 
Partition: ID-1: / raw size: 923.23 GiB size: 907.67 GiB (98.31%) used: 17.76 GiB (2.0%) 
           fs: ext4 dev: /dev/sda2 
           ID-2: swap-1 size: 8.00 GiB used: 0 KiB (0.0%) fs: swap swappiness: 15 (default 60) 
           cache pressure: 100 (default) dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 53.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 938 
Repos:     Active apt repos in: /etc/apt/sources.list 
           1: deb bullseye main non-free contrib
           2: deb-src bullseye main non-free contrib
           3: deb bullseye-updates main non-free contrib
           4: deb-src bullseye-updates main non-free contrib
           5: deb experimental main
           6: deb-src experimental main
           Active apt repos in: /etc/apt/sources.list.d/debian-stable-updates.list 
           1: deb bullseye-updates main contrib non-free
           Active apt repos in: /etc/apt/sources.list.d/debian.list 
           1: deb bullseye main contrib non-free
           Active apt repos in: /etc/apt/sources.list.d/mx.list 
           1: deb bullseye main non-free
           No active apt repos in: /etc/apt/sources.list.d/various.list 
Info:      Processes: 237 Uptime: 14m Memory: 19.53 GiB used: 1.59 GiB (8.1%) Init: SysVinit 
           v: 2.96 runlevel: 5 default: 5 Compilers: gcc: 10.2.1 alt: 10 Shell: quick-system-in 
           running in: quick-system-in inxi: 3.0.36 


Best place to start the investigation

What’s happening here? Looks like a Debian 11 install.

I installed MX Linux 21 beta on iMac and its running fine with no issues.

Tried to install Manjaro and other arch based distros and they all are crashing on black screen ( i think when startx command).

AMD Graphics card is faulty and as soon as it arch distro loads it, it crashes. Is there a way I can disable it using kernel commands like radeon,modeset=0 or nomodeset? But unfortunately the grub menu does not appear and i am seeing black screen.

Can you try the 5.4 kernel Manjaro ISO?


Many thanks.

Its gone further than black screen but when it tries to display the grub menu, its using the discrete amd gpu instead of integrated intel. As amd gpu is faulty, the screen has blue veritcal lines going across and cant see screen. Is there a way to make intel the default and disable the amd?