I'm pretty dumb so I came here to get help modify /etc/fstab so that my 2nd hard drive works

Nope. Its fine too.

k that’s good because I don’t see a /media folder
i feel like i should

o nevermind I typed it in

why is my /mnt folder root only? the GUI doesn’t let me change it :confused:

It is supposed to be root only.
Everything on / or root is root only. Except for maybe /tmp

Give the Downloads mountpoint ownership to your user.

Don’t mount to /mnt. Mount to a folder inside.

More details on mounting there:


btw an interesting thing happened, I think I had a windows session that didlnt’ close down or something because when I mounted using the command line it said this

"The disk contains an unclean file system (0, 0).

Metadata kept in Windows cache, refused to mount."

"Falling back to read-only mount because the NTFS partition is in an

unsafe state. Please resume and shutdown Windows fully (no hibernation

or fast restarting.)

Could not mount read-write, trying read-only

Wait I thought you meant inside /mnt ! you seem to mean a different location.

Why does the mount commant have a dollar sign in front?

$ sudo mount /dev/sdyX $mount/mydisk

You need to disable Fast Startup.

Create a folder inside /mnt /media (/mnt is actually not recommended for permanent mounts). That folder shall serve as mount point.

Also, please don’t post screenshots for text you could copy/paste.

1 Like

sure thing thanks

That dollar sign is not part of the command. It is supposed to represent a non-privileged UNIX shell command prompt ─ the root prompt would be # ─ in text mediums that do not support text formatting, such as Usenet discussion groups. Here on the forum it’s not needed.

Actually, if this is data specific to one user only, then a better choice for a mountpoint would be a directory inside the user’s ${HOME}.

hmm okay, I get this is supposed to be for NTFS , perhaps for dual boot disks. I think I want to just format this HDD to ext4 (i’ve already emptied it and formated) also I have a linux only boot ssd

If you defined an entry in /etc/fstab for your former partition, then next is to edit that entry for the new one, changing at least:

  • UUID
  • filesystem

Yeah thanks, I just commented it out so that it would boot. I will identify it by UUID because I understand that that’s more robust.

You are correct when you said earlier that the the “echo” looked kind of cryptic to me, I’m not sure what that does.

I was thinking of doing it a couple way if you might be inclined to check my work:

sudo mount /dev/sdb2 /run/media/WD930

I thought that I could if by command do it this way, above.

Or if I was to edit the /etc/fstab it might look like this: (note: the partition seems to be ext4, even though I don’t remember doing that, I just formatted it as NTFS on a windows 10 machine.

UUID=4268DB9368DB8457 /run/media/WD930 users 0 0

for reference below my KDE properties when I right clicked on the partition from the KDE partition manager looks like this (forgive me for pasting an image, I didn’t want to miss anything but I know I could have copied text)

    /run/media  sudo mount -t ext4 /dev/sdb1 /run/media/WD930                                12 ✘ 
mount: /run/media/WD930: wrong fs type, bad option, bad superblock on /dev/sdb1, missing codepage or helper program, or other error.

UUID=639c9705-e321-46f7-b7c3-c5dc78b6fafc /run/media/WD930 users 0 0

The partition’s filesystem type is mandatory in /etc/fstab.

Thanks I’ll take a look at the wiki!
I guess I want to use the UUID for the partition. It’s interesting I note the UUID changed after things changed, I’m assuming bc I formatted the drive.

I reckon the following should be sufficient because it’s not a boot drive, if it’s a boot drive it seems like it requires echo and some of those other parameters and commands I’m less familiar with.

UUID=68EE887F-57E9-4EF7-BC08-FFFCAF3E371D /run/media/WD930/ ext4 users 0 0

hmm didn’t work, I think I need an maybe noatime or “defaults”

Okay well I cheated a little bit and used the GUI for part of it but it used the drive UUID and then I got it to boot! However the permissions still show the user and group as “root” and I think that’s still a problem.

UUID=c2f92357-b8f2-441f-8c99-eb076d5bcb9a /run/media/WD930 ext4 defaults 0 0

<fsck> sets the order for file system checks at boot time; see fsck(8). For the root device it should be 1. For other partitions it should be 2, or 0 to disable checking.

From the wiki it seems like it should be okay for the to be “0” so I have something to figure out yet.

this thread seems to address it How do I change ownership for a hard disk?

sudo chown -R xiaohan:xiaohan /run/media/WD930/

hmmm last thing that looks wrong is that it seems to have a complete linux file tree of its own as if it were a main or boot drive