I'm have problem in grub or boot Manjaro

hi guys please help me i cant boot manjaro im enter update-grub
comment in live usb terminal but its problem

please helppppp

its error:

[ manjaro / ] # update - grub Generating grub configuration file Found theme : Warning : os - prober will be executed to detect other bootable partitions . Its output will be used to detect bootable binaries on them and create new boot entries . ERROR : mkdir / var / lock / dmraid grub - probe : error : cannot find a GRUB drive for / dev / sdb1 . Check your device.map . grub - probe : error : cannot find a GRUB drive for / dev / sdb1 . Check your device.map . Found memtest86 + image : /boot/memtest86+/memtest.bin done /usr/share/grub/themes/manjaro/theme.txt

link error screenshot:


I see you have tried to update grub, but have you tried to reinstall grub? If not this Manjaro wiki page may help.

1 Like

I had a look at the freeimage host picture.
Can you give some more information about your system ?
The system has a raid array.

yes yes I have already installed grub

asus e202sa

ram 4 gib

hard 500 gib

why raid array ??!

The freeimage shows dmraid.

You should try to reinstall Grub2.

Please help me reinstall grub

yes i am ready to guide me step by step i am now in terminal via live usb now i have entered lsblk command and this is the result :


sda1 = boot/efi
sda2 = boot (manjaro installation)
sda3 = swap driver
sda4 = ntfs driver

is the manjaro a fresh install?
check in bios if AHCI is enabled

no i have manjaro ago but now i cant boot

so just to be sure, manjaro was working normally and now you cant boot?
so what did you do? system update, isntalled something, uninstalled something etc…?

I connected a usb to my system, then when I restarted the system, Manjaro did not boot anymore

what was on the usb? did you modify some bios settings?

usb is empty next im go the bios and change items

please open this link and see photo:


again, did you change anything in bios?

No, I only tweaked the BIOS once

Did you see the picture?

so you didnt change anything in bios before the manjaro broke?
yes i saw it … but we need to found out why you cant boot into manjaro…
are you chrooted in the live usb session?

No, I didn’t change anything in the bios before my Manjaro crashed, now I can’t log into my Manjaro, and now I’m logged in via live usb, and yes, I can enter the chroot, please guide me step by step

so enter chroot and run this first:
sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu
any errors copy here!

ok bro please wait im send screen shot link please see that