I'm getting mad installing autofs


I have a simple problem: how to install autofs
I have found it is on AUR. So I do: yay -S autofs

Thirst error: lex is not found…
→ so I tried to install lex. Bad news, il’s now known as flex. Ok.

Second error: yacc is not found. I’m getting a bit angry…
→ so I tried to install yacc. Bad news, yacc is not found. I tried pacman -Ss yacc and installed byacc then python-ply without success. I’m getting very angry…

What must I do???

Sounds like you’re missing base-devel.

sudo pacman -S base-devel



1 Like

It works ! Thanks a lot ! It (sorry) was not obvious.

But… if it is a base package, why isn’t it installed by default ?

1 Like

Its not a base package.
But it is a prerequisite for using the AUR.

1 Like

It’s for building software and packages, not something everyone does.

Also the AUR isn’t supported by Arch or Manjaro, and it’s up to the sys admin (probably you) to create and maintain the system you want.

It used to be a bit more obvious, base-devel has recently been changed from a group to a metapackage. With a group you can see which packages are members of the group.

pacman -F yacc
core/bison 3.8.2-4 (base-devel) [installed: 3.8.2-5]
community/9base 6-8
community/bear 3.1.0-1
community/plan9port 20220818-1

Now we’ve lost the (base-devel) bit.

sudo pacman -Fy yacc
core/bison 3.8.2-5 [installed]

I’d prefer to see the metapackage shown, maybe something like below so we know it’s a metapackage and not a group. However that’s up to the Arch devs.

core/bison 3.8.2-5 {base-devel} [installed]


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.