Ignore AUR package in pamac

I’ve installed the packages gcc8 and gcc8-libs from the official repositories. But now, as they were removed from the official repos, pamac is trying to update them using the AUR packages. However, during this upgrade process these packages are built from scratch, which takes a long time.

I couldn’t find a way to tell pamac to ignore these packages from AUR, so that when I run “pamac update -a” they are skipped. I tried adding them to the section IgnorePkg in the /etc/pacman.conf file but it did not work.

Change in Preferences - on AUR tab - disable AUR update check.

Why do you need gcc8 to begin with?

That’s the right way to accomplish what you want. Maybe a typo? What’s the output of:

cat /etc/pacman.conf | grep IgnorePkg
1 Like

If you are using the pamac gui in preferences there’s an option to add individual packages to be ignored when updating. I do it all the time with git craken as I really don’t want the latest version :grin:

I need gcc8 and gcc8-libs because they are a dependency for the cuda package version 10.2.

The output of the command is:

IgnorePkg   = gcc8-libs cuda gcc8

When I run pamac checkupdates -a , these packages are correctly marked as ignored:

1 available update:
dropbox      111.4.472-1 -> 112.4.321-1  AUR

3 ignored updates:
cuda         10.2.89-2   -> 11.1.1-1     community
gcc8         8.3.0-4     -> 8.4.0-2      AUR
gcc8-libs    8.3.0-4     -> 8.4.0-2      AUR

However, when I run pamac update -a , it looks like pamac still tries to update the gcc8-libs package.

Cloning dropbox build files...
Checking dropbox dependencies...
Cloning gcc8 build files...
Checking gcc8-libs dependencies...
Synchronizing package databases...
Warning: cuda: ignoring package upgrade (10.2.89-2 => 11.1.1-1)
Warning: gcc8: ignoring package upgrade (8.3.0-4 => 8.4.0-2)
Warning: gcc8-libs: ignoring package upgrade (8.3.0-4 => 8.4.0-2)
Error: Failed to prepare transaction: target not found: gcc8-libs

Edit build files : [e] 
Apply transaction ? [e/y/N] y

Transaction cancelled.

If you specifically need 10.2, then why not install cuda-10.2? Then you don’t need to add anything to IgnorePkg.

That is odd. @guinux