Icons Show as Boxes

Greetings! I have an issue where some icons are not displayed correctly. Instead they show as boxes. Does anyone know the fix for this problem?

Hello. Which icons?
On the panel, the desktop, in Nemo, the applications menu…?

I would guess it’s a theme problem. Try changing your theme and see if the issue persists.

dldotuploadgramdotme/606c6af3c838dh?raw A screenshot sample is here. Just replace the word ‘dot’ for period. It affects the entire system no matter what applications/programs I use.

I have the same problem after this morning updates.
All icons themes are the same, some icons themes disappeared, some gtk themes doesn’t work (Qogir panel bar is transparent). I think that something is broken.

Same for me no more icons theme choice Cinnamon theme setting…!

Anyone solve this ?

So you’re saying there is no icon themes to select from in the Theme settings?

Yes since the today update…

A lot of my icons doesn’t appear

Strange. Did you try to reboot already?

Is package papirus-icon-theme for example still installed?

Yes i reboot and yes papirus-icon-theme and my other theme are installed just not displayed in theme setting …?

Rebooted and reinstalled some icons themes.
Now themes works (after a reinstall) but icons not. Also in Gimp, for example, the icons disappeared.
ibb DOT co/nzy38Hf

Try running cinnamon-settings themes from the terminal. Do you see any errors or warning in the terminal output ?

Any errors in ~/.xsession-errors ?

Yes i’ve got a lot of error in .xsession-errors.
I haven’t got any problems before this update…

I saw that changing “Window borders” have no effect…???

This is the output

/usr/share/cinnamon/cinnamon-settings/cinnamon-settings.py:430: DeprecationWarning: Gtk.Window.set_wmclass is deprecated
  self.window.set_wmclass(wm_class, wm_class)

This is .xsession-errors

(cinnamon:1309): St-WARNING **: 17:06:55.659: Failed to load /usr/share/themes/Flat-Remix-GTK-Green-Darker/cinnamon/assets/switch-off.svg: Formato del file di immagine non riconosciuto

(cinnamon:1309): St-CRITICAL **: 17:06:55.659: _st_create_texture_pipeline: assertion 'src_texture != NULL' failed

(cinnamon:1309): Clutter-WARNING **: 17:06:57.476: clutter-actor.c:10052: Actor 'StBoxLayout' tried to allocate a size of -4,00 x 16,00

(cinnamon:1309): St-WARNING **: 17:09:01.945: Failed to load /usr/share/themes/Flat-Remix-GTK-Green-Darker/cinnamon/assets/close.svg: Formato del file di immagine non riconosciuto

(cinnamon:1309): St-CRITICAL **: 17:09:01.946: _st_create_texture_pipeline: assertion 'src_texture != NULL' failed
** Message: 17:11:26.434: updates_checker.vala:71: check updates
** Message: 17:11:26.723: updates_checker.vala:101: 0 updates found

Nothing strange I think in this file.

I’ve found a solution. As root:

pacman -Qqn | pacman -S -

Full reinstall of all packages, at the reboot of the system icons and interface worked as always.

1 Like

You are the best !!! All work fine !!! Thank you so much !!!