Icon Only Task Manager Error KDE 5.22.3

The update to KDE 5.22.3 went pretty well. But I get this error from the icon only task manager. I am forced to use a window list instead.

I unchecked “tooltips” in the configuration but that makes no difference.

file:///home/dougrrr/.local/share/plasma/plasmoids/org.kde.plasma.taskmanager/contents/ui/main.qml:220:9: Cannot assign to non-existent property “toolTipItem”

This is a Plasmoid you installed yourself?

Plasma Task Manager is not installed in the user folder as far as I know. Should be here /usr/share/plasma/plasmoids/org.kde.plasma.taskmanager/

I guess you should use the Plasma provided one, and not the one in your user home, which is probably outdated and not working in current Plasma. Maybe try to use another one temporarily, remove the local one, and reboot and try to see if you can select it again now (which should be the official provided one).


[omano@omano-nvme ~]$ pacman -Qo /usr/share/plasma/plasmoids/org.kde.plasma.taskmanager/contents/ui/main.qml
/usr/share/plasma/plasmoids/org.kde.plasma.taskmanager/contents/ui/main.qml is owned by plasma-desktop 5.22.3-1

should be installed by default as it is part of Plasma itself.

The one I was using is the one that is the default in KDE. I installed nothing!!

To me this is definitely a local copy of the Plasmoid. I use this task manager and I don’t have this folder there, the only folders I have there are my manually installed Plasmoids. Therefore, it seems you have a local version of this Plasmoid in your user folder.

What is output of ls ~/.local/share/plasma/plasmoids/ ?

//EDIT: you can right click the taskbar, then go to (not sure exact names as my OS is not in English) Add Graphic Component → Get New Components → Download… then it should open the KDE Store windows, and filter on top right with Show Installed instead of Show All or Show Updatable. It should list the locally installed Plasmoids from the KDE Store. If you see it installed from here you may be able to remove it from here. If it was not installed locally from here, I’m not sure the right procedure, I would “YOLO” it and delete the folder /home/dougrrr/.local/share/plasma/plasmoids/org.kde.plasma.taskmanager/ but there might be a better way.

//EDIT2: maybe the proper way to remove locally installed Plasmoid when not installed from KDE Store is kpackagetool5 -t Plasma/Applet --remove /home/dougrrr/.local/share/plasma/plasmoids/org.kde.plasma.taskmanager/ (from quick google, not sure)

1 Like

Will check it out! Later,.

Below is the output of that command. I removed the taskmanager entry with Krusader but I see it is still listed. Hmm.

I tried reinstalling taskmanager but still get the same error.



























So all these are manually installed Plasmoids. You may not remember installing them, but you did.

Not sure what you did as I didn’t talk about Krusader. I gave you two methods that seem OK to properly uninstall this local task manager.

Check from the KDE Store from the taskbar

or manually execute the remove command.


as I said it is part of KDE Plasma I don’t know why you want to install it. I told you to get rid of the local one you have in the user folder, so it uses the one provided by KDE. The local one takes priority over the one provided by KDE Plasma in theory.

1 Like

I removed it again. I rebooted and it is working now. Thanks!

1 Like

As a PS, if you want over the top task management
add the Kwin script Parachute and the companion script to toggle in using a screen edge command. Parachute gives you big thumnails of all the things you have open and running.

I have it set to pop across the screen when I put my mouse in the upper right corner, but you can set it to any part of the screen edges you want.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.